summaryrefslogtreecommitdiff
path: root/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-29 02:53:24 +0000
commitb8ec9071f5d20d8518b02d0077428b2c9f88861b (patch)
tree6214c0d63a2bd5ae464941924a90f415687fa63c /dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
parentbdf6e70da7a28f45617c02a251bb6b3844202bc5 (diff)
gentoo auto-resync : 29:01:2023 - 02:53:24
Diffstat (limited to 'dev-ml/core_unix/core_unix-0.15.2-r1.ebuild')
-rw-r--r--dev-ml/core_unix/core_unix-0.15.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
new file mode 100644
index 000000000000..d15597a32049
--- /dev/null
+++ b/dev-ml/core_unix/core_unix-0.15.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit dune
+
+DESCRIPTION="Unix-specific portions of Core"
+HOMEPAGE="https://github.com/janestreet/core_unix"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.09
+ dev-ml/core:=
+ dev-ml/core_kernel:${SLOT}
+ dev-ml/expect_test_helpers_core:${SLOT}
+ dev-ml/ocaml_intrinsics:${SLOT}
+ dev-ml/spawn:${SLOT}
+ dev-ml/timezone:${SLOT}
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""