summaryrefslogtreecommitdiff
path: root/dev-ml/deriving/deriving-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/deriving/deriving-0.7.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/deriving/deriving-0.7.1.ebuild')
-rw-r--r--dev-ml/deriving/deriving-0.7.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/deriving/deriving-0.7.1.ebuild b/dev-ml/deriving/deriving-0.7.1.ebuild
new file mode 100644
index 000000000000..845c827a8b68
--- /dev/null
+++ b/dev-ml/deriving/deriving-0.7.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A deriving library for Ocsigen"
+HOMEPAGE="https://github.com/ocsigen/deriving"
+SRC_URI="https://github.com/ocsigen/deriving/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/type-conv-108:=
+ dev-ml/optcomp:=
+ dev-ml/findlib:=
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/oasis"
+
+DOCS=( CHANGES README.md )
+oasis_configure_opts="--enable-tc"
+OASIS_SETUP_COMMAND="./setup.exe"
+
+src_configure() {
+ emake setup.exe
+ oasis_src_configure
+}