summaryrefslogtreecommitdiff
path: root/dev-ml/dns-lwt-unix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/dns-lwt-unix
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/dns-lwt-unix')
-rw-r--r--dev-ml/dns-lwt-unix/Manifest3
-rw-r--r--dev-ml/dns-lwt-unix/dns-lwt-unix-1.0.0.ebuild45
-rw-r--r--dev-ml/dns-lwt-unix/metadata.xml11
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/dns-lwt-unix/Manifest b/dev-ml/dns-lwt-unix/Manifest
new file mode 100644
index 000000000000..c5b1728eb19a
--- /dev/null
+++ b/dev-ml/dns-lwt-unix/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 BLAKE2B f0fa068296ac7eb5331ff7f5f88ee60a3010ac146f4b5bfeeffc8db014e6e5563da4f516ee1090365d290fb50b2754576b14167d55b2a33e125046103d485c1e SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c
+EBUILD dns-lwt-unix-1.0.0.ebuild 814 BLAKE2B e372a572d541fa7fed10863932e6d21aece8e42714fbc767f3c2546f5d08318949ef6e7476b238aa15b3730c007bc7dfb0edae2c37103114fba6a94f3e0cdd92 SHA512 a2bcc276d0d4cf28ae7e0e957e04e58c3619a2f2439c089be602210a0831e8c593756eb0a416c82fe5cbb044d32b683305afa30419bf1c25624932d7984847b7
+MISC metadata.xml 357 BLAKE2B e22ffef8d3776a5f01c87a83bf859dcde8f35940885c9e86535debf56beefc5e2ec5dc99c041f208304d2238118ecf814b95c6cd27b18368c10d0889416cbe59 SHA512 9e3065fb6377e861b64a34f9fafd75e33a0edb081d273a8918b494a1d6f79c63ffb2c9b33bd854bb893fa020652c15b575d3e16e08266895239c082f28429633
diff --git a/dev-ml/dns-lwt-unix/dns-lwt-unix-1.0.0.ebuild b/dev-ml/dns-lwt-unix/dns-lwt-unix-1.0.0.ebuild
new file mode 100644
index 000000000000..0de745104dd6
--- /dev/null
+++ b/dev-ml/dns-lwt-unix/dns-lwt-unix-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib opam
+
+MY_P=ocaml-dns-${PV}
+
+DESCRIPTION="Lwt support of OCaml DNS"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-dns/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/dns-lwt:=
+ dev-ml/dns:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ dev-ml/ocaml-ipaddr:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ test? (
+ dev-ml/ounit
+ )
+ ${RDEPEND}
+"
+# Do not work
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ jbuilder build @install -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN} || die
+}
diff --git a/dev-ml/dns-lwt-unix/metadata.xml b/dev-ml/dns-lwt-unix/metadata.xml
new file mode 100644
index 000000000000..2f4ef14adaa5
--- /dev/null
+++ b/dev-ml/dns-lwt-unix/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-dns</remote-id>
+ </upstream>
+</pkgmetadata>