summaryrefslogtreecommitdiff
path: root/dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
commit57c2e006d0af9ab77ced676461d7100cade4a716 (patch)
treefedd61a96505af97dea0e78425b1b7a70b813a46 /dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild
parent664924d8659185e3b43f99ee8a0b88177efb93dc (diff)
gentoo auto-resync : 23:11:2022 - 01:07:24
Diffstat (limited to 'dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild')
-rw-r--r--dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild b/dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild
new file mode 100644
index 000000000000..b7bbc45378bb
--- /dev/null
+++ b/dev-ml/dune-build-info/dune-build-info-3.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Embed locations informations inside executable and libraries"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND=">=dev-ml/dune-3.0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p ${PN} @install --display short -j $(makeopts_jobs) || die
+}