summaryrefslogtreecommitdiff
path: root/dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-13 01:41:21 +0100
commitb89a664f266dab3b9b5ddac2cb874f8869142370 (patch)
tree21d127b0b99c1505ba548bc05975b9fcecda871e /dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild
parent7e662ec84fc13cef513542e4030f47017d030187 (diff)
gentoo auto-resync : 13:10:2022 - 01:41:21
Diffstat (limited to 'dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild')
-rw-r--r--dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild94
1 files changed, 3 insertions, 91 deletions
diff --git a/dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild b/dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild
index 289317f1072a..b2716c4b3f5c 100644
--- a/dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild
+++ b/dev-ml/dune-configurator/dune-configurator-2.9.3.ebuild
@@ -13,103 +13,15 @@ S="${WORKDIR}/dune-${PV}"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-IUSE="+ocamlopt test"
-RESTRICT="!test? ( test )"
+IUSE="+ocamlopt"
+RESTRICT="test" #test run within dev-ml/dune-private-libs
RDEPEND="
~dev-ml/dune-private-libs-${PV}:=[ocamlopt?]
dev-ml/csexp:=[ocamlopt?]
dev-ml/result:=[ocamlopt?]
"
-DEPEND="${RDEPEND}
- test? (
- dev-ml/core_bench
- dev-ml/menhir
- dev-ml/opam
- dev-ml/ppx_expect
- )
-"
-# TODO for test deps:
-# Add cram?
-# Add dev-ml/js_of_ocaml once dev-ml/ocaml-base64 is ported to Dune
-# Add coq?
-
-src_prepare() {
- default
-
- # Keep this list in sync with dev-ml/dune-private-libs
- local bad_tests=(
- # List of tests calling git, mercurial, etc
- test/blackbox-tests/test-cases/dune-project-meta/main.t
- test/blackbox-tests/test-cases/meta-template-version-bug.t
- test/blackbox-tests/test-cases/subst/project-name-restriction.t
- test/blackbox-tests/test-cases/subst/with-opam-file.t
- test/blackbox-tests/test-cases/subst.t
- test/blackbox-tests/test-cases/subst/unicode.t
- test/blackbox-tests/test-cases/subst/from-project-file.t
- test/blackbox-tests/test-cases/trace-file.t
- otherlibs/build-info/test/run.t
- test/expect-tests/vcs_tests.ml
-
- # Strange failures, seemingly from newer versions of deps
- test/blackbox-tests/test-cases/merlin/allow_approximate_merlin_warn.t
- test/blackbox-tests/test-cases/merlin/merlin-tests.t
- test/blackbox-tests/test-cases/merlin/github4125.t
- test/blackbox-tests/test-cases/install-dry-run.t
- test/blackbox-tests/test-cases/c-flags.t
- test/blackbox-tests/test-cases/install-libdir.t
- test/blackbox-tests/test-cases/dune-cache/trim.t
-
- # Strange failures about opam not being initialised
- test/blackbox-tests/test-cases/merlin/merlin-from-subdir.t
- test/blackbox-tests/test-cases/merlin/symlinks.t
- test/blackbox-tests/test-cases/merlin/src-dirs-of-deps.t
- test/blackbox-tests/test-cases/merlin/per-module-pp.t
- test/blackbox-tests/test-cases/merlin/server.t
- test/blackbox-tests/test-cases/github1946.t
- test/blackbox-tests/test-cases/github759.t
-
- # Wants nodejs!
- test/blackbox-tests/test-cases/jsoo/simple.t
- test/blackbox-tests/test-cases/jsoo/inline-tests.t
- test/blackbox-tests/test-cases/jsoo/github3622.t
- # Wants js_of_ocaml (can't include yet b/c of ocaml-base64 porting)
- test/blackbox-tests/test-cases/jsoo/explicit-js-mode-specified.t
-
- # Wants coq which doesn't build for me right now
- test/blackbox-tests/test-cases/coq/rec-module.t
- test/blackbox-tests/test-cases/coq/compose-sub-theory.t
- test/blackbox-tests/test-cases/coq/native-compose.t
- test/blackbox-tests/test-cases/coq/base-unsound.t
- test/blackbox-tests/test-cases/coq/base.t
- test/blackbox-tests/test-cases/coq/native-single.t
- test/blackbox-tests/test-cases/coq/compose-simple.t
- test/blackbox-tests/test-cases/coq/ml-lib.t
- test/blackbox-tests/test-cases/coq/extract.t
- test/blackbox-tests/test-cases/coq/compose-plugin.t
-
- # Unpackaged dependencies (a rabbit hole for now)
- # utop -> lambda-term, zed
- test/blackbox-tests/test-cases/utop/github3188.t
- test/blackbox-tests/test-cases/utop/utop-simple.t
- test/blackbox-tests/test-cases/utop/utop-default.t
- test/blackbox-tests/test-cases/utop/utop-default-implementation.t
- test/blackbox-tests/test-cases/utop/utop-ppx-rewriters.t
- # ocamlformat
- test/blackbox-tests/test-cases/formatting.t
- # mdx
- test/blackbox-tests/test-cases/mdx-stanza.t
- # odoc
- test/blackbox-tests/test-cases/odoc/odoc-simple.t
- test/blackbox-tests/test-cases/odoc/odoc-package-mld-link.t
- test/blackbox-tests/test-cases/odoc/multiple-private-libs.t
- test/blackbox-tests/test-cases/odoc/odoc-unique-mlds.t
- test/blackbox-tests/test-cases/odoc/github717-odoc-index.t
- test/blackbox-tests/test-cases/odoc/warnings.t
- )
-
- rm -r ${bad_tests[@]} || die "Failed to remove broken/inappropriate tests"
-}
+DEPEND="${RDEPEND}"
src_configure() {
: