summaryrefslogtreecommitdiff
path: root/dev-ml/dyn/dyn-3.16.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /dev-ml/dyn/dyn-3.16.0.ebuild
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'dev-ml/dyn/dyn-3.16.0.ebuild')
-rw-r--r--dev-ml/dyn/dyn-3.16.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/dyn/dyn-3.16.0.ebuild b/dev-ml/dyn/dyn-3.16.0.ebuild
new file mode 100644
index 000000000000..a96b11c1fd35
--- /dev/null
+++ b/dev-ml/dyn/dyn-3.16.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Dynamic type"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3.12"
+DEPEND="~dev-ml/ordering-${PV}:=[ocamlopt?]"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ${PN}
+}