summaryrefslogtreecommitdiff
path: root/dev-ml/fmt/fmt-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/fmt/fmt-0.8.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/fmt/fmt-0.8.4.ebuild')
-rw-r--r--dev-ml/fmt/fmt-0.8.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/fmt/fmt-0.8.4.ebuild b/dev-ml/fmt/fmt-0.8.4.ebuild
new file mode 100644
index 000000000000..19b27b4284d0
--- /dev/null
+++ b/dev-ml/fmt/fmt-0.8.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib opam
+
+DESCRIPTION="Combinators to devise OCaml Format pretty-printing functions"
+HOMEPAGE="http://erratique.ch/software/fmt https://github.com/dbuenzli/fmt"
+SRC_URI="http://erratique.ch/software/fmt/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-ml/result:=[ocamlopt]
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/uchar:=[ocamlopt]
+ dev-ml/cmdliner:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/topkg-0.9
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test 'true' 'false') || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}