summaryrefslogtreecommitdiff
path: root/dev-ml/fpath/fpath-0.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-28 10:27:13 +0100
commitf4fc10428424904caf2035cffc442195cb088b2c (patch)
tree72f320d5963e55586cfdeed2b14c72b8191b6327 /dev-ml/fpath/fpath-0.7.3.ebuild
parentfbd9734cedfe790955100b8e4ab3613457d77b1a (diff)
gentoo resync : 28.07.2021
Diffstat (limited to 'dev-ml/fpath/fpath-0.7.3.ebuild')
-rw-r--r--dev-ml/fpath/fpath-0.7.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/fpath/fpath-0.7.3.ebuild b/dev-ml/fpath/fpath-0.7.3.ebuild
new file mode 100644
index 000000000000..13e85c27b103
--- /dev/null
+++ b/dev-ml/fpath/fpath-0.7.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="File system paths for OCaml"
+HOMEPAGE="https://erratique.ch/software/fpath https://github.com/dbuenzli/fpath"
+SRC_URI="https://erratique.ch/software/fpath/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-ml/result:=
+ dev-ml/astring:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}