summaryrefslogtreecommitdiff
path: root/dev-ml/graphics/graphics-5.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-ml/graphics/graphics-5.1.1-r1.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-ml/graphics/graphics-5.1.1-r1.ebuild')
-rw-r--r--dev-ml/graphics/graphics-5.1.1-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/graphics/graphics-5.1.1-r1.ebuild b/dev-ml/graphics/graphics-5.1.1-r1.ebuild
new file mode 100644
index 000000000000..7a3977c3a2ce
--- /dev/null
+++ b/dev-ml/graphics/graphics-5.1.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="The OCaml graphics library"
+HOMEPAGE="https://github.com/ocaml/graphics"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+
+RDEPEND="dev-ml/dune-configurator:=[ocamlopt?]
+ >=dev-lang/ocaml-4.09:=
+ x11-libs/libX11:="
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+IUSE="+ocamlopt"