summaryrefslogtreecommitdiff
path: root/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-21 17:32:00 +0100
commit61f10f985e19dfe20a4d9552902625edd5b6eabb (patch)
tree50db31971b38c4e0358253ef5005058a46fc773e /dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild
parent34dea8e38f88007799629d0a56b12dec480b1d21 (diff)
gentoo resync : 21.06.2021
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild
new file mode 100644
index 000000000000..c72639216ff3
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.24.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gsl"
+inherit dune
+
+MY_P=${P/-ocaml/}
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/${PV}/${MY_P}.tbz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/dune-configurator
+ >=sci-libs/gsl-1.19:="
+RDEPEND="${DEPEND}
+ !dev-ml/ocamlgsl"
+
+# DOCS=( CHANGES.txt README.md NOTES.md TODO.md )