summaryrefslogtreecommitdiff
path: root/dev-ml/iTeML/iTeML-2.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-17 17:51:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-17 17:51:45 +0100
commit420eeee727d39d869d864caddb04a80dafda7160 (patch)
tree87f15d7467082dd92fce78a6cc2f56fa8d0774af /dev-ml/iTeML/iTeML-2.7.ebuild
parent0fdd4074ff3dc0c507a9867380a4f91250a0b610 (diff)
gentoo resync : 17.10.2017
Diffstat (limited to 'dev-ml/iTeML/iTeML-2.7.ebuild')
-rw-r--r--dev-ml/iTeML/iTeML-2.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/iTeML/iTeML-2.7.ebuild b/dev-ml/iTeML/iTeML-2.7.ebuild
new file mode 100644
index 000000000000..90e9f8676bf7
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ >=dev-ml/qcheck-0.5:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}