summaryrefslogtreecommitdiff
path: root/dev-ml/iTeML
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/iTeML
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/iTeML')
-rw-r--r--dev-ml/iTeML/Manifest7
-rw-r--r--dev-ml/iTeML/iTeML-2.5.ebuild30
-rw-r--r--dev-ml/iTeML/iTeML-2.6.ebuild30
-rw-r--r--dev-ml/iTeML/iTeML-2.7.ebuild30
-rw-r--r--dev-ml/iTeML/metadata.xml11
5 files changed, 108 insertions, 0 deletions
diff --git a/dev-ml/iTeML/Manifest b/dev-ml/iTeML/Manifest
new file mode 100644
index 000000000000..b72a641198a2
--- /dev/null
+++ b/dev-ml/iTeML/Manifest
@@ -0,0 +1,7 @@
+DIST iTeML-2.5.tar.gz 33750 BLAKE2B 362dcbd0a2e44842832ec5e2307eb2f291013344e80b791f1e2c3e5ffc43633f67c7e736ad3a6545197467700d043649080b5f8889b55e460748f769ca7f404b SHA512 b8a2f842f0076bdf3f30a71983f686b931ac3f7fde73ad83041dae1d33d8bca2c7695b71dcc53ef942fbdee7422e2e4d22994f69b70d54e2b4d62bc1c64395c9
+DIST iTeML-2.6.tar.gz 34822 BLAKE2B feb7a1d7973f1710b245cb5d859d443b4c30a6128137523659768864cdd23eb18606a2b6d418d9fb37784bf2fe53fc45a4558e1565186e2402574df560a4afc5 SHA512 6c42856d8a8d6b9e76002fe94e4be0db2a108c4a033fd3d19849772a6c1db9b792beb960b0ac02973d40dc9dda4c4cf5ba13ae9f05534798cc3ccc283f8d3567
+DIST iTeML-2.7.tar.gz 34866 BLAKE2B c3d2df6901ca1c5a804b8e5becf2960f6de10a0edc88fab86fadd39ec25d35143d5ccb3765a1bb5e4d55f28d1dc8942085b964b343dc1f8622ea4438b842e9a6 SHA512 477b55332ab4f733bb225fb15741e5129314fc857900715851027b132fd87f169f8d402987762bd9a07e0a644b1d2bbd49e2f21de7cc23edbe89ff8b3f2bda65
+EBUILD iTeML-2.5.ebuild 616 BLAKE2B 8701d46e53561cfefc823af98c8912fe061321c7a5444c83757f7a2fea634f81124d4209a59cadfb5df9588bd9fc29285628932192fd39c826df85e1b0607b19 SHA512 201b4767bae5d86e8ee937f557b69396c97315f44c181803bc5aa8117fda265cb0eefdc3cf13cac6f6828a16040479ad9a03dbbd497877b0e44f65f7325fc8ea
+EBUILD iTeML-2.6.ebuild 616 BLAKE2B 8701d46e53561cfefc823af98c8912fe061321c7a5444c83757f7a2fea634f81124d4209a59cadfb5df9588bd9fc29285628932192fd39c826df85e1b0607b19 SHA512 201b4767bae5d86e8ee937f557b69396c97315f44c181803bc5aa8117fda265cb0eefdc3cf13cac6f6828a16040479ad9a03dbbd497877b0e44f65f7325fc8ea
+EBUILD iTeML-2.7.ebuild 616 BLAKE2B 8701d46e53561cfefc823af98c8912fe061321c7a5444c83757f7a2fea634f81124d4209a59cadfb5df9588bd9fc29285628932192fd39c826df85e1b0607b19 SHA512 201b4767bae5d86e8ee937f557b69396c97315f44c181803bc5aa8117fda265cb0eefdc3cf13cac6f6828a16040479ad9a03dbbd497877b0e44f65f7325fc8ea
+MISC metadata.xml 341 BLAKE2B efb397231b9a2c53e6229e93161a2c62c6fbf23b0b1b46441e1d43abe7485a399a6fb5cb9eb93aef2bbbf61c68b6042cd9909fed32f4fbf95a60cb84f286bd37 SHA512 c3f8f5f72ae96e9050b7c11de89ca754ac84019a857388e53a56cec3122020e06d7d6143b0cf9070f509cd62f1c32d4f52a2e4b3593a73b6fea8d41fc23d6385
diff --git a/dev-ml/iTeML/iTeML-2.5.ebuild b/dev-ml/iTeML/iTeML-2.5.ebuild
new file mode 100644
index 000000000000..7047a3ea4d8d
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ >=dev-ml/qcheck-0.5:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}
diff --git a/dev-ml/iTeML/iTeML-2.6.ebuild b/dev-ml/iTeML/iTeML-2.6.ebuild
new file mode 100644
index 000000000000..7047a3ea4d8d
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ >=dev-ml/qcheck-0.5:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}
diff --git a/dev-ml/iTeML/iTeML-2.7.ebuild b/dev-ml/iTeML/iTeML-2.7.ebuild
new file mode 100644
index 000000000000..7047a3ea4d8d
--- /dev/null
+++ b/dev-ml/iTeML/iTeML-2.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Inline (Unit) Tests for OCaml"
+HOMEPAGE="https://github.com/vincent-hugot/iTeML"
+SRC_URI="https://github.com/vincent-hugot/iTeML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/ounit:=
+ dev-lang/ocaml:=[ocamlopt]
+ >=dev-ml/qcheck-0.5:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+"
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake BIN="${ED}/usr/bin/" install
+ dodoc README.adoc HOWTO.adoc
+}
diff --git a/dev-ml/iTeML/metadata.xml b/dev-ml/iTeML/metadata.xml
new file mode 100644
index 000000000000..4e400b4f2b2a
--- /dev/null
+++ b/dev-ml/iTeML/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vincent-hugot/iTeML</remote-id>
+ </upstream>
+</pkgmetadata>