summaryrefslogtreecommitdiff
path: root/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-06 04:25:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-06 04:25:47 +0100
commitf5d9305cc82b2e211fdaba92618c07829ffb2c48 (patch)
tree430648fb68a5308f8831702d5a970e476ca4e91c /dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
parent0234994edb2122d4508c5a07122e774bcab9195b (diff)
gentoo auto-resync : 06:09:2022 - 04:25:47
Diffstat (limited to 'dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild')
-rw-r--r--dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
new file mode 100644
index 000000000000..fd85ad9de73a
--- /dev/null
+++ b/dev-ml/lablgtk-sourceview/lablgtk-sourceview-3.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DUNE_PKG_NAME=lablgtk3-sourceview3
+
+inherit dune
+
+DESCRIPTION="OCaml bindings to GTK-3"
+HOMEPAGE="https://github.com/garrigue/lablgtk"
+SRC_URI="https://github.com/garrigue/lablgtk/archive/${PV}.tar.gz
+ -> lablgtk-${PV}.tar.gz"
+S="${WORKDIR}"/lablgtk-${PV}
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="3/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/lablgtk-${PV}:3=
+ dev-ml/cairo2:=
+ x11-libs/gtksourceview:3.0=
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ echo "(version ${PV})" >> "${S}"/dune-project || die
+}
+
+src_compile() {
+ dune build --profile release -p ${DUNE_PKG_NAME} || die
+}