summaryrefslogtreecommitdiff
path: root/dev-ml/llvm-ocaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /dev-ml/llvm-ocaml
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/Manifest1
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild127
2 files changed, 128 insertions, 0 deletions
diff --git a/dev-ml/llvm-ocaml/Manifest b/dev-ml/llvm-ocaml/Manifest
index 4a25e7f8c61b..b3d9fface7ef 100644
--- a/dev-ml/llvm-ocaml/Manifest
+++ b/dev-ml/llvm-ocaml/Manifest
@@ -7,5 +7,6 @@ EBUILD llvm-ocaml-5.0.2.ebuild 2984 BLAKE2B 723a1e859c8e35f2ece65cc8dd6fdd4ef130
EBUILD llvm-ocaml-6.0.1.ebuild 3148 BLAKE2B 08a61098a9782694f57d4a56dd450200abdc1fb117ff327e4005c8f81d1b5cb861bba0fdadb19e94e3d4c409b1431a5ce361bc77b0ce590c69b855b1d866e1f5 SHA512 b0cc43ae38254cf01688e4a5b375452c8d17e9a8cae89a43ea1635383516d217850f16e605de3c45c8cef993ec9c95fbcf98f4333e27770000cae6899615e631
EBUILD llvm-ocaml-7.0.1.ebuild 3145 BLAKE2B f44a8f4a741085912c7e89e6d5c892e0e7d004e9d2a2023016fef717392c2e0437c16ea8904443253f36a2bd16a1224b66309c462ebc43a9383f083542f89603 SHA512 717075157b6d130b9997fba55728a1071a6f4d490266e3e5fc9828dea180423158790b16f94262c94425667c242f7c4217e4b640fbac532ff9b2af2fcb80c62d
EBUILD llvm-ocaml-7.0.9999.ebuild 3160 BLAKE2B b87ef20af15615aa962f44423b376e54f3c034a3c4e65a9683122f58646303182a71ba7dcaccd5d1c11820171dda1572f21c29cd03cce307cf847de60b350706 SHA512 c62ee53ef2e03f28d5c1ff70ae68f415dcde714481ff0615f276a6a370f193e2682f01dd9add191ed8266ad308a0115cb610197202bda8bb5229305bf546c88f
+EBUILD llvm-ocaml-8.0.9999.ebuild 3157 BLAKE2B 16ef8ac673332d268b27d7f3762d9201b1f57fecab95f28a6d0f76020cb5bb1ada1fc262026c9e7a8bb596f796e7bc8e6202030e4642e8c19b56a450e19d56d0 SHA512 90ea92899bd20841c53e356d1213aeb4beb23c694ebfef057b5df2692b3deef55c0d4f3574a3a4eb4d1a322915ce4b313a486f5019ffcf3e3725b12b51501ee9
EBUILD llvm-ocaml-9999.ebuild 3386 BLAKE2B a935bebd7fccdf631999ba3be52a70072c5cccf1fdceaf48c72a584f0409afa82c0956913d3682eefed4d01f35afe1b91dd323721bfe0599cdf8f2fdabd3a8b3 SHA512 01fbc7546f9da6aea63888b3b1fb65971555a323dee902611e1c240145d91ce60e46aaed7331797ffde6f7864d0bc270bb9ef8ab3cbaa16dfcff92414aac0e2f
MISC metadata.xml 216 BLAKE2B fe5e49887842aa513fbf1f2e09bed09a884d531fd21bdaeb2d389e8bf590b6c0e7063f0af98f66e2db129308ab0f0804ba327c3c752bbb4c900c59ac109d99aa SHA512 3485598147c953e72e1785693a489a7e7d73d59620b76054db9c0ce95d8bfa0e8ffec29da7f7a9d73a32e5b77eac07ca3306c56a972dc57fd89d477edaebf3d5
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild
new file mode 100644
index 000000000000..1857f99418c1
--- /dev/null
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-8.0.9999.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
+# (needed due to CMAKE_BUILD_TYPE != Gentoo)
+CMAKE_MIN_VERSION=3.7.0-r1
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils git-r3 llvm multiprocessing python-any-r1
+
+DESCRIPTION="OCaml bindings for LLVM"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/llvm.git
+ https://github.com/llvm-mirror/llvm.git"
+EGIT_BRANCH="release_80"
+
+# Keep in sync with sys-devel/llvm
+ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
+ NVPTX PowerPC Sparc SystemZ X86 XCore )
+ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
+LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
+
+LICENSE="UoI-NCSA"
+SLOT="0/${PV}"
+KEYWORDS=""
+IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.00.0:0=
+ dev-ml/ocaml-ctypes:=
+ ~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
+ !sys-devel/llvm[ocaml(-)]"
+# configparser-3.2 breaks the build (3.3 or none at all are fine)
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-ml/findlib
+ test? ( dev-ml/ounit )
+ !!<dev-python/configparser-3.3.0.2
+ ${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ || ( ${ALL_LLVM_TARGETS[*]} )"
+
+# least intrusive of all
+CMAKE_BUILD_TYPE=RelWithDebInfo
+
+pkg_setup() {
+ LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Python is needed to run tests using lit
+ python_setup
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
+
+ -DBUILD_SHARED_LIBS=ON
+ -DLLVM_OCAML_OUT_OF_TREE=ON
+ -DLLVM_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
+ -DLLVM_BUILD_TESTS=$(usex test)
+
+ # disable various irrelevant deps and settings
+ -DLLVM_ENABLE_FFI=OFF
+ -DLLVM_ENABLE_TERMINFO=OFF
+ -DHAVE_HISTEDIT_H=NO
+ -DWITH_POLLY=OFF
+ -DLLVM_ENABLE_ASSERTIONS=$(usex debug)
+ -DLLVM_ENABLE_EH=ON
+ -DLLVM_ENABLE_RTTI=ON
+
+ -DLLVM_HOST_TRIPLE="${CHOST}"
+
+ # disable go bindings
+ -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
+
+ # TODO: ocamldoc
+ )
+
+ use test && mycmakeargs+=(
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ )
+
+ # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
+ # also: custom rules for OCaml do not work for CPPFLAGS
+ use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
+ cmake-utils_src_configure
+
+ local llvm_libdir=$(llvm-config --libdir)
+ # an ugly hack; TODO: figure out a way to pass -L to ocaml...
+ cd "${BUILD_DIR}/${libdir}" || die
+ ln -s "${llvm_libdir}"/*.so . || die
+
+ if use test; then
+ local llvm_bindir=$(llvm-config --bindir)
+ # Force using system-installed tools.
+ sed -i -e "/llvm_tools_dir/s@\".*\"@\"${llvm_bindir}\"@" \
+ "${BUILD_DIR}"/test/lit.site.cfg.py || die
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile ocaml_all
+}
+
+src_test() {
+ # respect TMPDIR!
+ local -x LIT_PRESERVES_TMP=1
+ cmake-utils_src_make check-llvm-bindings-ocaml
+}
+
+src_install() {
+ DESTDIR="${D}" \
+ cmake -P "${BUILD_DIR}"/bindings/ocaml/cmake_install.cmake || die
+
+ dodoc bindings/ocaml/README.txt
+}