summaryrefslogtreecommitdiff
path: root/dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild')
-rw-r--r--dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild b/dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild
new file mode 100644
index 000000000000..acc14d95595a
--- /dev/null
+++ b/dev-ml/lwt_ssl/lwt_ssl-1.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="GLib integration for Lwt"
+SRC_URI="https://github.com/ocsigen/lwt/archive/${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE=""
+
+RDEPEND="
+ >=dev-ml/lwt-3.1:=
+ >=dev-ml/ocaml-ssl-0.4.0:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~arm ~ppc ~x86-fbsd"
+S="${WORKDIR}/lwt-${P}/"
+
+src_compile() {
+ jbuilder build -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN} || die
+}