summaryrefslogtreecommitdiff
path: root/dev-ml/mtime/mtime-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ml/mtime/mtime-1.3.0.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ml/mtime/mtime-1.3.0.ebuild')
-rw-r--r--dev-ml/mtime/mtime-1.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/mtime/mtime-1.3.0.ebuild b/dev-ml/mtime/mtime-1.3.0.ebuild
new file mode 100644
index 000000000000..a6d491ea6add
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-js_of_ocaml false \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}