summaryrefslogtreecommitdiff
path: root/dev-ml/mtime/mtime-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-16 22:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-16 22:07:44 +0100
commitc4507bfdfd706b2b1301972490fe88ac3ddbc70e (patch)
tree72500f6288cf79e445e6a5cb03337f4f64ce49db /dev-ml/mtime/mtime-2.0.0.ebuild
parentaa0b5f37afc4a88422d6301d07e4e3852ddd7251 (diff)
gentoo auto-resync : 16:05:2023 - 22:07:44
Diffstat (limited to 'dev-ml/mtime/mtime-2.0.0.ebuild')
-rw-r--r--dev-ml/mtime/mtime-2.0.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/mtime/mtime-2.0.0.ebuild b/dev-ml/mtime/mtime-2.0.0.ebuild
new file mode 100644
index 000000000000..89bcf7cd92cc
--- /dev/null
+++ b/dev-ml/mtime/mtime-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime/
+ https://github.com/dbuenzli/mtime/"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ edo ocaml pkg/pkg.ml build \
+ --tests $(usex test true false)
+}
+
+src_test() {
+ edo ocaml pkg/pkg.ml test
+}