summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild')
-rw-r--r--dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
new file mode 100644
index 000000000000..0056e666f79f
--- /dev/null
+++ b/dev-ml/ocaml-dispatch/ocaml-dispatch-0.3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Path-based dispatching for client- and server-side applications"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-dispatch"
+SRC_URI="https://github.com/inhabitedtype/ocaml-dispatch/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="javascript"
+
+DEPEND="
+ javascript? ( dev-ml/js_of_ocaml:=[ppx,ocamlopt?] )
+ dev-ml/result:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( "README.md" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable javascript js-of-ocaml)" \
+ oasis_src_configure
+}