summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild')
-rw-r--r--dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
new file mode 100644
index 000000000000..d9e81851498d
--- /dev/null
+++ b/dev-ml/ocaml-gettext/ocaml-gettext-0.4.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="gettext"
+inherit dune
+
+DESCRIPTION="Provides support for internationalization of OCaml program"
+HOMEPAGE="https://github.com/gildor478/ocaml-gettext"
+SRC_URI="https://github.com/gildor478/ocaml-gettext/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-ml/cppo-1.6.6
+ dev-ml/dune-configurator
+"
+RDEPEND="
+ dev-ml/base:=
+ >=dev-ml/camomile-0.8.3:=
+ >=dev-ml/ocaml-fileutils-0.4.0:=
+ sys-devel/gettext
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-ml/ounit )
+"
+
+src_install() {
+ dune_src_install
+}