summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-hashcons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ml/ocaml-hashcons
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ml/ocaml-hashcons')
-rw-r--r--dev-ml/ocaml-hashcons/Manifest2
-rw-r--r--dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild16
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-ml/ocaml-hashcons/Manifest b/dev-ml/ocaml-hashcons/Manifest
index 645ef1d15dc7..9f5f5d42e8e4 100644
--- a/dev-ml/ocaml-hashcons/Manifest
+++ b/dev-ml/ocaml-hashcons/Manifest
@@ -1,3 +1,3 @@
DIST ocaml-hashcons-1.3.tar.gz 19495 BLAKE2B 0d29a529fb1d6953e7294e3992e6f41c094e8b4ea607ed4f2f0d97c558b2c9a6e8703de0aca06727b845ad3f3989ef99c634e248f221c95fbffc2321cd73e961 SHA512 fd194d48a3231e72ca8bf3d324e5e1f6442d965da9149973a1763cf70aa82398805fa00648bdd12de3d3daada8e90bdc575c73886f949b5183e79bea75beadc8
-EBUILD ocaml-hashcons-1.3.ebuild 856 BLAKE2B e8d2f6d399d40ca83b447c7c5a18ba8ed34c5d0b5b272852119ff8352dbe9111923e732a3ae5d01c33be478efff7e3c9174e6011f7216d149ae2f3807aefac38 SHA512 4b0f2ac976990f2086bbb37f8168b3756ec0fd845483db3eae2ca7f3c7ee7424ba6bdbb14b33b31dbf434654c34fe66cf9d14ec00aa4f833c8b2df8285523714
+EBUILD ocaml-hashcons-1.3.ebuild 885 BLAKE2B 5717313c262c96f23a87f39c2ffbe568f444c367bdf98281e7527e2622fb96349b5f88d095b6b6f484f18bf3fedbd0ef8351466cb7a2463ec6ca5290a3208f96 SHA512 15e40c8da43f58f23b87569b4034122115126b2e156e26dc090e7341d16339c7a573580f26cd8b39f83ef66477cb7b65e017b6794dc4f395f2fb339f8dd34b70
MISC metadata.xml 259 BLAKE2B 72d093b371aa2735e9f81201fb32b5fe3e6ae2e3074c86be4e6f85c026d6a81cbeb3a82ca72ac6dbfe4ff3785e5661843b32d8f859ce50fad3823f218fed84c5 SHA512 ee8ee05e2b4f71e1e2b73d210db65707f53606f2943406f41a12759a4d024bd4cfbfc6f8c8e6ddf37e199adb10b7501aca1f2dc6e6704590221e50bec20bbeec
diff --git a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
index 7b027961ea87..e059ea1b1938 100644
--- a/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
+++ b/dev-ml/ocaml-hashcons/ocaml-hashcons-1.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools findlib
@@ -18,7 +18,10 @@ RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
DEPEND="${RDEPEND}"
src_prepare() {
+ default
+
eautoreconf
+
sed -i -e 's/$(OCAMLFIND) remove/#/' Makefile.in || die
}
@@ -31,7 +34,12 @@ src_compile() {
}
src_install() {
- dodir "$(ocamlfind printconf destdir)/hashcons"
- emake DESTDIR="-destdir ${D}/$(ocamlfind printconf destdir)/" $(usex ocamlopt install-opt install-byte)
+ local destdir=$(ocamlfind printconf destdir || die)
+ dodir ${destdir}/hashcons
+
+ emake \
+ DESTDIR="-destdir ${D}"/${destdir}/ \
+ $(usex ocamlopt install-opt install-byte)
+
dodoc README.md CHANGES
}