summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild')
-rw-r--r--dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
new file mode 100644
index 000000000000..c4a103f9a450
--- /dev/null
+++ b/dev-ml/ocaml-ipaddr/ocaml-ipaddr-2.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+DESCRIPTION="OCaml library for manipulation of IP (and MAC) address representations"
+HOMEPAGE="https://github.com/mirage/ocaml-ipaddr"
+SRC_URI="https://github.com/mirage/ocaml-ipaddr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="dev-ml/sexplib:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ dev-lang/ocaml:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/findlib
+ test? ( dev-ml/ounit )
+"
+
+src_install() {
+ opam_src_install ipaddr
+}