summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-sha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-sha
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-sha')
-rw-r--r--dev-ml/ocaml-sha/Manifest3
-rw-r--r--dev-ml/ocaml-sha/metadata.xml11
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild28
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/Manifest b/dev-ml/ocaml-sha/Manifest
new file mode 100644
index 000000000000..fb0cdd42c139
--- /dev/null
+++ b/dev-ml/ocaml-sha/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-sha-v1.9.tar.gz 12872 BLAKE2B 382431814ef1fd4b88e69ff727fade617a7a6e2757a70e7538e2fc5b2708572a731b6800e9c36b7ddcb1c6103b57a1ccd14c5bc6886e83f56ebc388de9f67c90 SHA512 e49f725f0544a423c57199b2534519a005916f24a17bf7761e744ec963c5712b8b0b82b052d87c55fdfd3143f194f44283c7332ab08f480328c0c21642ae5778
+EBUILD ocaml-sha-1.9.ebuild 589 BLAKE2B 2f1416778a27394908a0f964c4533e7c3d18cb18da1a4774f91d62c0003b233e8795b0d506c160a3b4dec169d5fbc022e65dec7a3e74f1f874e6b88261c9f743 SHA512 d638d64f7ba75a12dc0106d14f68257afaa422ff5721a7a905612d7c00e8c6520fb877f34afb13e499afed6659f69b03412c1e2df6e1cfde5fdfa9d27ab19100
+MISC metadata.xml 341 BLAKE2B 18b973592d9c3d2d911ef36f206339eea91bc7b39da886ee5d1c59ad733c20c63bf13260741daf378257a458f44bd001283e676b843913b1539a91045c8f4381 SHA512 0944b63ad7a82f331296d7ae17f705de27793719a5ae023f84ec046c062d1b1de0f8910131b2b86e7f50190349e4788c149c46c85dd31ac3928964830d968aab
diff --git a/dev-ml/ocaml-sha/metadata.xml b/dev-ml/ocaml-sha/metadata.xml
new file mode 100644
index 000000000000..3499afc663c2
--- /dev/null
+++ b/dev-ml/ocaml-sha/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vincenthz/ocaml-sha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
new file mode 100644
index 000000000000..d8d3f5e48761
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="https://github.com/vincenthz/ocaml-sha"
+SRC_URI="https://github.com/vincenthz/ocaml-sha/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}