summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild
new file mode 100644
index 000000000000..93d736e30add
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/releases/download/${PV}/${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:="
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README.md
+}