summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-webmachine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-webmachine
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-webmachine')
-rw-r--r--dev-ml/ocaml-webmachine/Manifest3
-rw-r--r--dev-ml/ocaml-webmachine/metadata.xml11
-rw-r--r--dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/ocaml-webmachine/Manifest b/dev-ml/ocaml-webmachine/Manifest
new file mode 100644
index 000000000000..6c2df4fd6a59
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml-webmachine-0.4.0.tar.gz 74818 BLAKE2B cc9491a8761ebec463ec9c496e7cc84944d554bc6e43d8b20af55af9fd5d597783816f81a68bd9866a462e24dab09fd5da6c7ff327295177981677ddf91e6a08 SHA512 5ea06ae41f6c156786b72ea7a164bd0c96cf9b6fc7ae1e93044a928681f03b07cef39da1c4955317fe6762065bd189b3809ba521b3349ec9f6dde9191c857d31
+EBUILD ocaml-webmachine-0.4.0.ebuild 702 BLAKE2B 0b7bd483871a24f691195c14d187a5fcc1d86a2377997ba5bb5c163fde5e92c952b21cf3823d92d388b473a2d701740544e1c92b2076729df379fa540143e8f1 SHA512 00208a9a1c7a0fc0fb26d456de2d072e3f577c5b228285faf532d74fae4a6ebbf56a356187f9210bfbe83f1b49a84640a43109ffdd1ca94e1af4440ee1bb3166
+MISC metadata.xml 342 BLAKE2B 14908f5ea94e1073bae326e92af106aedcb3d42835a0dcfe48042a15b50982b69ec1e52f5a282ab461ba10d237acbd2c9ecaf865897ea9b81e8eef116099c8c1 SHA512 804592c0559ff0ac827914218f41ed8865820660571b2cf4f6ac583e499b94ee694ef4cb7a7f627d3d4d6874f1cbf65ac98fa711df6c6213dd9a7430e1347453
diff --git a/dev-ml/ocaml-webmachine/metadata.xml b/dev-ml/ocaml-webmachine/metadata.xml
new file mode 100644
index 000000000000..16ee3a041382
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">inhabitedtype/ocaml-webmachine</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild b/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild
new file mode 100644
index 000000000000..1f8b5e502946
--- /dev/null
+++ b/dev-ml/ocaml-webmachine/ocaml-webmachine-0.4.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A REST toolkit for OCaml"
+HOMEPAGE="https://github.com/inhabitedtype/ocaml-webmachine"
+SRC_URI="https://github.com/inhabitedtype/ocaml-webmachine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/calendar:=
+ dev-ml/ocaml-cohttp:=[ocamlopt?]
+ dev-ml/ocaml-dispatch:=[ocamlopt(+)?]
+ dev-ml/ocaml-re:=[ocamlopt?]
+ dev-ml/ocaml-uri:=[ocamlopt(+)?]
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? ( dev-ml/ounit[ocamlopt?] )
+"
+
+DOCS=( README.md CONTRIBUTING.md )