summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml_intrinsics
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/ocaml_intrinsics
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/ocaml_intrinsics')
-rw-r--r--dev-ml/ocaml_intrinsics/Manifest3
-rw-r--r--dev-ml/ocaml_intrinsics/metadata.xml11
-rw-r--r--dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml_intrinsics/Manifest b/dev-ml/ocaml_intrinsics/Manifest
new file mode 100644
index 000000000000..4e179fe352e5
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/Manifest
@@ -0,0 +1,3 @@
+DIST ocaml_intrinsics-0.15.1.tar.gz 24925 BLAKE2B 15d74ee891aced288aa734ef4d70a4816f2d2725d0d445620154bec7d1667d3ac06c5ddd778777d15858cbf198ecd978b22959fe68e159ddd9dbbd32304c3077 SHA512 cb0ac26bc34c97eb0429e6833342dbd9fca6f1f4a40b8121f9e6364bd2cdc40676a164d7405454727ced9a4455adb0e3cac5118beb7ab70206adbd3e7f7937e2
+EBUILD ocaml_intrinsics-0.15.1.ebuild 515 BLAKE2B 3d7d3bd127410d1f55bfa9f1e48a24cf6d9961c320bf6d0376207944035568f2648484b3df6faad4d0293f8139fda912991072b819ef4b7ebc1d0d0ac6d08df4 SHA512 015d46740fe8433b24da39935cb1301c28c89a97c3d6995f4dd193a774a12520211e2329e4b14e96f07bbe129c2260660dc2aa5b7da05900377a457215d22965
+MISC metadata.xml 326 BLAKE2B 737c6608b5b4282d53fb3e866199fbb672076c968f849b0f5b9a5da732c6db556b7b5f597e5d90e53a2a607cf02e7cbc01a5453e6e483721b47e2451cbe1285d SHA512 be860a17f734273b190dca122353092b24fbd0c37dfcf4121c28171227a412b29c92d063a21e6d767f4679bb3d92ac800fb621fec82f8d2fc45856252c19f5db
diff --git a/dev-ml/ocaml_intrinsics/metadata.xml b/dev-ml/ocaml_intrinsics/metadata.xml
new file mode 100644
index 000000000000..fec13523d489
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ocaml_instrinsics</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild
new file mode 100644
index 000000000000..e4b6ad5d30b8
--- /dev/null
+++ b/dev-ml/ocaml_intrinsics/ocaml_intrinsics-0.15.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="invoke amd64 instructions (such as clz,popcnt,rdtsc,rdpmc)"
+HOMEPAGE="https://github.com/janestreet/ocaml_intrinsics"
+SRC_URI="https://github.com/janestreet/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.08
+ dev-ml/dune-configurator:=
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""