summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlfuse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-13 07:36:05 +0100
commit5c0c70d5917e66743293789a6d6fd7d72250eb32 (patch)
treef6738b2393c696bb8b19bd6ff0e52aafadf65101 /dev-ml/ocamlfuse
parentc5806fcd6b740ecbd62f4fb2e09d8c8dfa2966fc (diff)
gentoo auto-resync : 13:07:2022 - 07:36:05
Diffstat (limited to 'dev-ml/ocamlfuse')
-rw-r--r--dev-ml/ocamlfuse/Manifest3
-rw-r--r--dev-ml/ocamlfuse/metadata.xml23
-rw-r--r--dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild37
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/ocamlfuse/Manifest b/dev-ml/ocamlfuse/Manifest
new file mode 100644
index 000000000000..37878c76756f
--- /dev/null
+++ b/dev-ml/ocamlfuse/Manifest
@@ -0,0 +1,3 @@
+DIST ocamlfuse-2.7.1_p7-r1.tar.gz 21469 BLAKE2B fa587d19124c2e2d320091bb42b098644d3112e39652dbf621c88f701effdab0ce15372b6f2461709eb3afe628e2888db3a7a0c9abeab8b8a136d09c69c84ac4 SHA512 342a6ce8a81ac05d47d4458ef6e9aa750e4e7643a89d28705664852f0549e1932643e8db5d93225ba496611654b3f11fef6aca1e6e40e8d4b30064fc9c65f7fd
+EBUILD ocamlfuse-2.7.1_p7-r1.ebuild 688 BLAKE2B 6c72ae2f700e635bf79b09d54922d6513eb673010b4598f49770c3edf887cc4d77123d506da59fd0154c8db3856ecabb07751aeb1d607076a565412b331eec74 SHA512 f9bc57c1a0b95ad15f6244026a9cbe7499e2249489187a4e5190a3863a3e61c8429ab9cc68f8277b4e10147fa935b33291f41ea0a848e195a6de6f1716c60ddb
+MISC metadata.xml 989 BLAKE2B 04cc7e720c9eaabf3e13d8a3671bf40162310524fd12c13ed23e17a50ad766c72fde4516b9be975ec8c2a1572e674971b8c71421070cd71b9063de45fbfb8b4e SHA512 aa026a7c35bfcffa35642470a704762e0e7a88bb834c93d7628d90bd1ad937479f6545ed3d75260060887bb22d0fc1f5134785948dbdfef357aebdf11a9caf55
diff --git a/dev-ml/ocamlfuse/metadata.xml b/dev-ml/ocamlfuse/metadata.xml
new file mode 100644
index 000000000000..c4853a8f842c
--- /dev/null
+++ b/dev-ml/ocamlfuse/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">This is a binding to FUSE for the OCaml programming language, enabling
+you to write multithreaded filesystems in the OCaml language. It has
+been designed with simplicity as a goal, as you can see by looking at
+example/fusexmp.ml. Efficiency has also been a separate goal. The
+Bigarray library is used for read and writes, allowing the library to
+do zero-copy in OCaml land.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/ocamlfuse/issues</bugs-to>
+ <remote-id type="github">astrada/ocamlfuse</remote-id>
+ <remote-id type="sourceforge">ocamlfuse</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
new file mode 100644
index 000000000000..fdf08ccbc300
--- /dev/null
+++ b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune toolchain-funcs
+
+MYPV="${PV/_p/_cvs}"
+
+DESCRIPTION="OCaml binding for fuse"
+HOMEPAGE="
+ https://sourceforge.net/projects/ocamlfuse/
+ https://github.com/astrada/ocamlfuse
+ https://opam.ocaml.org/packages/ocamlfuse
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${MYPV}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${MYPV}"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RDEPEND="
+ dev-ml/camlidl:=
+ sys-fs/fuse:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ dev-ml/opam
+"
+
+src_compile() {
+ tc-export CPP
+ dune_src_compile
+}