summaryrefslogtreecommitdiff
path: root/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild')
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
deleted file mode 100644
index a18399af37b0..000000000000
--- a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="OCaml SDL Bindings"
-
-HOMEPAGE="http://ocamlsdl.sourceforge.net"
-SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
-LICENSE="LGPL-2"
-
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ppc x86"
-IUSE="doc +ocamlopt opengl truetype" #noimage nomixer
-
-RDEPEND="
- >=dev-lang/ocaml-3.12:=[ocamlopt=]
- >=media-libs/libsdl-1.2
- opengl? ( >=dev-ml/lablgl-0.98:= )
- >=media-libs/sdl-mixer-1.2
- >=media-libs/sdl-image-1.2
- truetype? ( >=media-libs/sdl-ttf-2.0 )
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}/ocamlopt.patch"
-}
-
-src_configure() {
- myconf=""
- if use opengl; then
- destdir=`ocamlfind printconf destdir`
- lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
- if [ -z "${lablgldir}" ]; then
- destdir=`ocamlc -where`
- lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
- fi
-
- if [ ! -z "${lablgldir}" ]; then
- myconf="--with-lablgldir=${lablgldir}"
- fi
- fi
-
- #use noimage && myconf="${myconf} --without-sdl-image"
- #use nomixer && myconf="${myconf} --without-sdl-mixer"
-
- econf $myconf \
- `use_enable truetype sdl-ttf`
-}
-
-src_install() {
- findlib_src_install
-
- dodoc AUTHORS NEWS README
- doinfo doc/*.info*
-
- if use doc; then
- dohtml doc/html/*
- fi
-}