summaryrefslogtreecommitdiff
path: root/dev-ml/odoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 19:55:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 19:55:00 +0000
commit427ba64bd6bcdd59a1ae9bc7c5cec0299d135413 (patch)
tree2455e3903e1b27c27a2132c1d12c86d57011d7f8 /dev-ml/odoc
parent454de691f3543d47dc89cd0b137eaa9ea4640cd3 (diff)
gentoo auto-resync : 21:12:2022 - 19:55:00
Diffstat (limited to 'dev-ml/odoc')
-rw-r--r--dev-ml/odoc/Manifest3
-rw-r--r--dev-ml/odoc/metadata.xml16
-rw-r--r--dev-ml/odoc/odoc-2.2.0-r1.ebuild28
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-ml/odoc/Manifest b/dev-ml/odoc/Manifest
new file mode 100644
index 000000000000..e184813b3c9a
--- /dev/null
+++ b/dev-ml/odoc/Manifest
@@ -0,0 +1,3 @@
+DIST odoc-2.2.0.tbz 1548871 BLAKE2B 251c823e5f93e8080d52486e9d048a0c31651b6ea9d4bfdc3202488d7bcd750f9c2899189b943500253bf1e6041cf0283ed5e57c34d1a7d538c7c3710fb9a260 SHA512 9f8fc2ee6b25629474e8aa69dd460becab9277261578af0f7b97f7f779cc5f1056d1b5f14ab583b9b94ea097e5df2d6e35040f2a4887021209705486f9d44a22
+EBUILD odoc-2.2.0-r1.ebuild 567 BLAKE2B 2e4dcc03b3746d6ffa1fb484669eb24cf9db47adbb68918e65eed974c59af0ff57063c16e90de34c438ffcb0b50441fde664930ef50872994700b7cf8b2ee703 SHA512 c1f9292c3758fa145f10625af013faf70009f6f193ab0b1fb9268505ff0a3822db2eda526596d254223d6a5eadfcc3d85d2e7eec632849bb2707a6fa6f574a58
+MISC metadata.xml 522 BLAKE2B 04acd17984b96b5fdf41120b46c1f15ab1a2b9ccac7312ee27e41da5985cbed08786aa9349cec268f224bc660ea3fd902874bd029f37355685b2fcc8b7093b07 SHA512 d969745657f9335411b45ca5efe110da0d017dac7efe5d5357bdc6f99852c279d116aaa02101b443ef45229c1b9c809db65cfcd719ae48ddf198d5b2923b9f57
diff --git a/dev-ml/odoc/metadata.xml b/dev-ml/odoc/metadata.xml
new file mode 100644
index 000000000000..abc13e762b3e
--- /dev/null
+++ b/dev-ml/odoc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Odoc is a documentation generator for OCaml. It reads doc comments,
+ delimited with (** ... *), and outputs HTML
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml/odoc/issues/</bugs-to>
+ <remote-id type="github">ocaml/odoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/odoc/odoc-2.2.0-r1.ebuild b/dev-ml/odoc/odoc-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..5028b9801081
--- /dev/null
+++ b/dev-ml/odoc/odoc-2.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml documentation generator"
+HOMEPAGE="http://github.com/ocaml/odoc/"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="test" # ocaml-crunch not in the tree
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+ dev-ml/fmt:=
+ dev-ml/fpath:=
+ dev-ml/odoc-parser:=
+ dev-ml/result:=
+ dev-ml/tyxml:=
+"
+DEPEND="${RDEPEND}"