summaryrefslogtreecommitdiff
path: root/dev-ml/onanomsg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/onanomsg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/onanomsg')
-rw-r--r--dev-ml/onanomsg/Manifest6
-rw-r--r--dev-ml/onanomsg/files/bigstring.patch218
-rw-r--r--dev-ml/onanomsg/files/testrun.patch15
-rw-r--r--dev-ml/onanomsg/files/tests.patch12
-rw-r--r--dev-ml/onanomsg/metadata.xml14
-rw-r--r--dev-ml/onanomsg/onanomsg-1.0-r2.ebuild51
6 files changed, 316 insertions, 0 deletions
diff --git a/dev-ml/onanomsg/Manifest b/dev-ml/onanomsg/Manifest
new file mode 100644
index 000000000000..b9ea2e9d338a
--- /dev/null
+++ b/dev-ml/onanomsg/Manifest
@@ -0,0 +1,6 @@
+AUX bigstring.patch 8867 BLAKE2B 5239b7052baa461f6d7dcf2a55bb97733485f5bd81724f003d859d236e483360a418b5c9dd071fd57bf8228c696839df58de83652cc4dbea4260c12dc843dadb SHA512 b64e1f718f966bb34d1e9251cf2046a9489399796f37a83e88c00a053691f153032d6339150e5bf11ee937f3cf59e460eec94498fad3bd0be938622b3fc93032
+AUX testrun.patch 538 BLAKE2B d715a9b15064ba17d3044e31807fa7f97434194177513f954de97d9caf19bfa6a55e7118f30ddf27418619c3802ee1249cfa7f3e00b9684118df078d52bc9a40 SHA512 e91b4f0ad106ac5c2d46898d62c58dcc9a333a47fd46c506a166947d9526c88661a9692c733df841f161a07af71e7e5cb5ba894019c8a17c9af486ce4e84bbab
+AUX tests.patch 382 BLAKE2B e540c2608874f9c7ca90f19851479ca4918704e8c75ac3819602f0b69d2917b372e746c8c5bfed14d9b89183099c31137d3ff065baede52b17f64b252aa1d28f SHA512 543d1e47febd980cab47b5e1901c845cbf6fc39591ddf1b70ae1f3482a9499b8cb08b400907fa7059578377273e5e9565143ce8ad9a512f5e2a7a2a2fa989186
+DIST onanomsg-1.0.tar.gz 13519 BLAKE2B c50fb053082e4adfa77f3c6809fb29e64ac8dce7bb9fe1c506f6b7bf0fcd67a6de97f756956f103828ae2f334633f2500a95859c955bd0b610be38163a8d77b5 SHA512 d940f842f795c9d681755795f83694aceab23eb87c7cb66f2b8f643147ca58f30b43049e8c035e3f08392d9c2f611a75254d4ba999b337cc84d7b52f8f36218f
+EBUILD onanomsg-1.0-r2.ebuild 1117 BLAKE2B f20ad70039c78cda65c9bc32ea74d0efaa76e28b3b6dfe73755236271ee637627073aa702805cf330ec83de69ca87361b51af3ee517e6c4bc1679e50325e5f4b SHA512 bf821727516d1517ec04404d6d50d643cee41d37787052ec728555369d6fa8a981befd456598b74f388284683499e129eaefb5e21e21bdb84e63f9a86ebf7ae5
+MISC metadata.xml 392 BLAKE2B 5e95140580b94d7004658b18ec8dbf909a9799a4baea3f2e99d7ec13c235712b118dc9dcea4f0c0ad2f66317e893c508b2ff0ce49177a6d73af144793705f768 SHA512 12a4fbed87e735836701a952a145fc75a10ab333c06e1d465739d91db6a429e071f89399bc17e0367d2780bce7c7580344912e2afce51541334e8d5157477034
diff --git a/dev-ml/onanomsg/files/bigstring.patch b/dev-ml/onanomsg/files/bigstring.patch
new file mode 100644
index 000000000000..311fa2ee7495
--- /dev/null
+++ b/dev-ml/onanomsg/files/bigstring.patch
@@ -0,0 +1,218 @@
+Index: onanomsg-1.0/lib/nanomsg.ml
+===================================================================
+--- onanomsg-1.0.orig/lib/nanomsg.ml
++++ onanomsg-1.0/lib/nanomsg.ml
+@@ -209,7 +209,7 @@ let recv_fd sock =
+ (Obj.magic fd : Unix.file_descr)
+
+ let send_bigstring_buf ?(block=true) sock buf pos len =
+- if pos < 0 || len < 0 || pos + len > CCBigstring.size buf
++ if pos < 0 || len < 0 || pos + len > Bigstring.size buf
+ then invalid_arg "bounds";
+ let nn_buf = nn_allocmsg (size_of_int len) 0 in
+ match nn_buf with
+@@ -218,12 +218,12 @@ let send_bigstring_buf ?(block=true) soc
+ let nn_buf_p = Ctypes.(allocate (ptr void) nn_buf) in
+ let ba = Ctypes.(bigarray_of_ptr array1 len
+ Bigarray.char @@ from_voidp char nn_buf) in
+- CCBigstring.blit buf pos ba 0 len;
++ Bigstring.blit buf pos ba 0 len;
+ ignore @@ raise_notequal len
+ (fun () -> nn_send sock nn_buf_p nn_msg (int_of_bool block))
+
+ let send_bigstring ?(block=true) sock buf =
+- send_bigstring_buf ~block sock buf 0 @@ CCBigstring.size buf
++ send_bigstring_buf ~block sock buf 0 @@ Bigstring.size buf
+
+ let send_bytes_buf ?(block=true) sock buf pos len =
+ if pos < 0 || len < 0 || pos + len > Bytes.length buf
+@@ -235,7 +235,7 @@ let send_bytes_buf ?(block=true) sock bu
+ let nn_buf_p = Ctypes.(allocate (ptr void) nn_buf) in
+ let ba = Ctypes.(bigarray_of_ptr array1 len
+ Bigarray.char @@ from_voidp char nn_buf) in
+- CCBigstring.blit_of_bytes buf pos ba 0 len;
++ Bigstring.blit_of_bytes buf pos ba 0 len;
+ ignore @@ raise_notequal len
+ (fun () -> nn_send sock nn_buf_p nn_msg (int_of_bool block))
+
+@@ -266,16 +266,16 @@ let recv ?(block=true) sock f =
+ let recv_bytes_buf ?(block=true) sock buf pos =
+ recv ~block sock
+ (fun ba ->
+- let len = CCBigstring.size ba in
+- CCBigstring.(blit_to_bytes ba 0 buf pos len);
++ let len = Bigstring.size ba in
++ Bigstring.(blit_to_bytes ba 0 buf pos len);
+ len
+ )
+
+ let recv_bytes ?(block=true) sock =
+ recv ~block sock (fun ba ->
+- let len = CCBigstring.size ba in
++ let len = Bigstring.size ba in
+ let buf = Bytes.create len in
+- CCBigstring.blit_to_bytes ba 0 buf 0 len;
++ Bigstring.blit_to_bytes ba 0 buf 0 len;
+ buf)
+
+ let recv_string ?(block=true) sock =
+Index: onanomsg-1.0/lib/nanomsg.mli
+===================================================================
+--- onanomsg-1.0.orig/lib/nanomsg.mli
++++ onanomsg-1.0/lib/nanomsg.mli
+@@ -45,8 +45,8 @@ val close : socket -> unit
+
+ (** {2 Zero-copy I/O} *)
+
+-val send_bigstring : ?block:bool -> socket -> CCBigstring.t -> unit
+-val send_bigstring_buf : ?block:bool -> socket -> CCBigstring.t -> int -> int -> unit
++val send_bigstring : ?block:bool -> socket -> Bigstring.t -> unit
++val send_bigstring_buf : ?block:bool -> socket -> Bigstring.t -> int -> int -> unit
+
+ val send_string : ?block:bool -> socket -> string -> unit
+ val send_string_buf : ?block:bool -> socket -> string -> int -> int -> unit
+@@ -54,7 +54,7 @@ val send_string_buf : ?block:bool -> soc
+ val send_bytes : ?block:bool -> socket -> Bytes.t -> unit
+ val send_bytes_buf : ?block:bool -> socket -> Bytes.t -> int -> int -> unit
+
+-val recv : ?block:bool -> socket -> (CCBigstring.t -> 'a) -> 'a
++val recv : ?block:bool -> socket -> (Bigstring.t -> 'a) -> 'a
+ (** [recv ?block sock f] applies [f] to the received message. The
+ argument of [f] gets unallocated after [f] returns, so make sure
+ [f] {b never} let a reference to its argument escape. *)
+Index: onanomsg-1.0/lib/nanomsg_lwt.ml
+===================================================================
+--- onanomsg-1.0.orig/lib/nanomsg_lwt.ml
++++ onanomsg-1.0/lib/nanomsg_lwt.ml
+@@ -25,7 +25,7 @@ let raise_negative sock io_event f = rai
+ let raise_notequal sock io_event v f = raise_if sock io_event (fun x -> x <> v) f
+
+ let send_bigstring_buf sock buf pos len =
+- if pos < 0 || len < 0 || pos + len > CCBigstring.size buf
++ if pos < 0 || len < 0 || pos + len > Bigstring.size buf
+ then invalid_arg "bounds";
+ let nn_buf = nn_allocmsg (size_of_int len) 0 in
+ match nn_buf with
+@@ -34,14 +34,14 @@ let send_bigstring_buf sock buf pos len
+ let nn_buf_p = Ctypes.(allocate (ptr void) nn_buf) in
+ let ba = Ctypes.(bigarray_of_ptr array1 len
+ Bigarray.char @@ from_voidp char nn_buf) in
+- CCBigstring.blit buf pos ba 0 len;
++ Bigstring.blit buf pos ba 0 len;
+ raise_notequal sock Lwt_unix.Write len
+ (fun () -> nn_send (Obj.magic sock : int) nn_buf_p nn_msg
+ Symbol.(value_of_name_exn "NN_DONTWAIT")) >|= fun nb_written ->
+ ignore nb_written
+
+ let send_bigstring sock buf =
+- send_bigstring_buf sock buf 0 @@ CCBigstring.size buf
++ send_bigstring_buf sock buf 0 @@ Bigstring.size buf
+
+ let send_bytes_buf sock buf pos len =
+ if pos < 0 || len < 0 || pos + len > Bytes.length buf
+@@ -53,7 +53,7 @@ let send_bytes_buf sock buf pos len =
+ let nn_buf_p = Ctypes.(allocate (ptr void) nn_buf) in
+ let ba = Ctypes.(bigarray_of_ptr array1 len
+ Bigarray.char @@ from_voidp char nn_buf) in
+- CCBigstring.blit_of_bytes buf pos ba 0 len;
++ Bigstring.blit_of_bytes buf pos ba 0 len;
+ raise_notequal sock Lwt_unix.Write len
+ (fun () -> nn_send (Obj.magic sock : int) nn_buf_p nn_msg
+ Symbol.(value_of_name_exn "NN_DONTWAIT")) >|= fun nb_written ->
+@@ -84,16 +84,16 @@ let recv sock f =
+
+ let recv_bytes_buf sock buf pos =
+ recv sock (fun ba ->
+- let len = CCBigstring.size ba in
+- CCBigstring.blit_to_bytes ba 0 buf pos len;
++ let len = Bigstring.size ba in
++ Bigstring.blit_to_bytes ba 0 buf pos len;
+ Lwt.return len
+ )
+
+ let recv_bytes sock =
+ recv sock (fun ba ->
+- let len = CCBigstring.size ba in
++ let len = Bigstring.size ba in
+ let buf = Bytes.create len in
+- CCBigstring.blit_to_bytes ba 0 buf 0 len;
++ Bigstring.blit_to_bytes ba 0 buf 0 len;
+ Lwt.return buf
+ )
+
+Index: onanomsg-1.0/lib/nanomsg_lwt.mli
+===================================================================
+--- onanomsg-1.0.orig/lib/nanomsg_lwt.mli
++++ onanomsg-1.0/lib/nanomsg_lwt.mli
+@@ -4,8 +4,8 @@ open Nanomsg
+
+ (** {2 Zero-copy I/O} *)
+
+-val send_bigstring : socket -> CCBigstring.t -> unit Lwt.t
+-val send_bigstring_buf : socket -> CCBigstring.t -> int -> int -> unit Lwt.t
++val send_bigstring : socket -> Bigstring.t -> unit Lwt.t
++val send_bigstring_buf : socket -> Bigstring.t -> int -> int -> unit Lwt.t
+
+ val send_string : socket -> string -> unit Lwt.t
+ val send_string_buf : socket -> string -> int -> int -> unit Lwt.t
+@@ -13,7 +13,7 @@ val send_string_buf : socket -> string -
+ val send_bytes : socket -> Bytes.t -> unit Lwt.t
+ val send_bytes_buf : socket -> Bytes.t -> int -> int -> unit Lwt.t
+
+-val recv : socket -> (CCBigstring.t -> 'a Lwt.t) -> 'a Lwt.t
++val recv : socket -> (Bigstring.t -> 'a Lwt.t) -> 'a Lwt.t
+ (** [recv sock f] applies [f] to the received message. The
+ argument of [f] gets unallocated after [f] returns, so make sure
+ [f] {b never} let a reference to its argument escape. *)
+Index: onanomsg-1.0/_tags
+===================================================================
+--- onanomsg-1.0.orig/_tags
++++ onanomsg-1.0/_tags
+@@ -4,7 +4,7 @@ true: debug, bin_annot, safe_string
+ <lwt>: include
+ <lib_test>: include
+
+-<lib/nanomsg*>: package(containers.bigarray), \
++<lib/nanomsg*>: package(bigstring), \
+ package(ctypes), \
+ package(ipaddr), \
+ package(ppx_deriving.std), \
+@@ -13,7 +13,7 @@ true: debug, bin_annot, safe_string
+
+ <lib/nanomsg_lwt.*>: package(lwt.unix), package(lwt.ppx)
+
+-<lib_test/*>: package(containers.bigarray), \
++<lib_test/*>: package(bigstring), \
+ package(ctypes.foreign), \
+ package(ipaddr), \
+ package(lwt.unix), \
+@@ -21,7 +21,7 @@ true: debug, bin_annot, safe_string
+ package(oUnit), \
+ package(containers)
+
+-<examples/*>: package(containers.bigarray), \
++<examples/*>: package(bigstring), \
+ package(ctypes.foreign), \
+ package(ipaddr), \
+- package(containers)
+\ No newline at end of file
++ package(containers)
+Index: onanomsg-1.0/pkg/META
+===================================================================
+--- onanomsg-1.0.orig/pkg/META
++++ onanomsg-1.0/pkg/META
+@@ -1,6 +1,6 @@
+ version = "1.0"
+ description = "Bindings to nanomsg"
+-requires = "ctypes.foreign ipaddr ppx_deriving.std containers containers.bigarray"
++requires = "ctypes.foreign ipaddr ppx_deriving.std containers bigstring"
+ archive(byte) = "nanomsg.cma"
+ archive(byte, plugin) = "nanomsg.cma"
+ archive(native) = "nanomsg.cmxa"
+@@ -15,4 +15,4 @@ package "lwt" (
+ archive(native) = "nanomsg_lwt.cmxa"
+ archive(native, plugin) = "nanomsg_lwt.cmxs"
+ exists_if = "nanomsg_lwt.cma"
+-)
+\ No newline at end of file
++)
diff --git a/dev-ml/onanomsg/files/testrun.patch b/dev-ml/onanomsg/files/testrun.patch
new file mode 100644
index 000000000000..e78dadaf3625
--- /dev/null
+++ b/dev-ml/onanomsg/files/testrun.patch
@@ -0,0 +1,15 @@
+Drop Surveyor / Respondant tests as they fail.
+
+Index: onanomsg-1.0/lib_test/suite.ml
+===================================================================
+--- onanomsg-1.0.orig/lib_test/suite.ml
++++ onanomsg-1.0/lib_test/suite.ml
+@@ -93,7 +93,7 @@ let connect_to_string_test ctx =
+
+ let socket_test ctx =
+ let domains = [AF_SP; AF_SP_RAW] in
+- let protos = [Pair; Pub; Sub; Req; Rep; Push; Pull; Surveyor; Respondant; Bus] in
++ let protos = [Pair; Pub; Sub; Req; Rep; Push; Pull; Bus] in
+ List.iter
+ (fun d ->
+ List.iter
diff --git a/dev-ml/onanomsg/files/tests.patch b/dev-ml/onanomsg/files/tests.patch
new file mode 100644
index 000000000000..f93d0ce51260
--- /dev/null
+++ b/dev-ml/onanomsg/files/tests.patch
@@ -0,0 +1,12 @@
+Index: onanomsg-1.0/_tags
+===================================================================
+--- onanomsg-1.0.orig/_tags
++++ onanomsg-1.0/_tags
+@@ -19,6 +19,7 @@ true: debug, bin_annot, safe_string
+ package(lwt.unix), \
+ package(lwt.ppx), \
+ package(oUnit), \
++ package(ppx_deriving), \
+ package(containers)
+
+ <examples/*>: package(bigstring), \
diff --git a/dev-ml/onanomsg/metadata.xml b/dev-ml/onanomsg/metadata.xml
new file mode 100644
index 000000000000..d59abf5ddf60
--- /dev/null
+++ b/dev-ml/onanomsg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <use>
+ <flag name="lwt">Enables lwt support.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rgrinberg/onanomsg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/onanomsg/onanomsg-1.0-r2.ebuild b/dev-ml/onanomsg/onanomsg-1.0-r2.ebuild
new file mode 100644
index 000000000000..d67ffaa0a2ce
--- /dev/null
+++ b/dev-ml/onanomsg/onanomsg-1.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam eutils
+
+DESCRIPTION="nanomsg bindings for OCaml"
+HOMEPAGE="https://github.com/rgrinberg/onanomsg"
+SRC_URI="https://github.com/rgrinberg/onanomsg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0/${PV}-bigstring"
+KEYWORDS="~amd64"
+IUSE="+lwt +ocamlopt test"
+
+RDEPEND="
+ dev-libs/nanomsg:=
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/ocaml-ctypes:=
+ dev-ml/ocaml-ipaddr:=[ocamlopt?]
+ dev-ml/sexplib:=
+ dev-ml/ppx_deriving:=[ocamlopt?]
+ dev-ml/ocaml-containers:=[ocamlopt?]
+ dev-ml/ocaml-bigstring:=
+ lwt? ( dev-ml/lwt:=[ocamlopt(+)?] )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/bigstring.patch" \
+ "${FILESDIR}/tests.patch" \
+ "${FILESDIR}/testrun.patch"
+ default
+}
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ lwt=$(usex lwt true false) \
+ ounit=$(usex test true false) \
+ || die
+}
+
+src_install() {
+ opam_src_install nanomsg
+ dodoc CHANGES README.md
+}