summaryrefslogtreecommitdiff
path: root/dev-ml/opam-installer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-24 03:02:55 +0000
commit530a5a826feeb71085fb8a01927f4d775a0b131b (patch)
treeb7669c45ea3f2a3a37b2437817a370226bb1c819 /dev-ml/opam-installer
parent71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (diff)
gentoo auto-resync : 24:11:2024 - 03:02:54
Diffstat (limited to 'dev-ml/opam-installer')
-rw-r--r--dev-ml/opam-installer/Manifest2
-rw-r--r--dev-ml/opam-installer/opam-installer-2.2.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ml/opam-installer/Manifest b/dev-ml/opam-installer/Manifest
index 117f70ed70a7..4195c441b01d 100644
--- a/dev-ml/opam-installer/Manifest
+++ b/dev-ml/opam-installer/Manifest
@@ -1,3 +1,5 @@
+DIST opam-2.2.1.tar.gz 1089671 BLAKE2B cd6a97c8c19d7866205b49f95bf4215d986b3ad8b5d1fe5c5fd52db9b8b9e0cff8559d478e18d99d89816bbf830910f182e4c1e80719ac29a3cd5c8299450a21 SHA512 17d7d83b9de118332c121b9d3aa2e48f62a6270ea23e730a536b0f4ff060df85238c7c4ab53a89bcc3b3193d52d14358831bd9bed30a4ac699e44e4c3003b8b0
DIST opam-full-2.1.6.tar.gz 11704198 BLAKE2B 20e74551760cadf1d911e72c34502e1e7e62003f8ebc83f3b9cb46c712e13fb5f85f41421cc74b051c2e348e0c0a17f4ea34bf655f7ec48cfcdab1e0d8a57a11 SHA512 2bb24db05dc39d6e8294c10b5a6bb2dd8f675a4d56e1dc9a2e9bc576f54d14a1709005219c25586df9382897ab7ba5ea0636765410f01c06958ec59be9f14b4c
EBUILD opam-installer-2.1.6.ebuild 964 BLAKE2B 824236ef82b27f3ec9bbb7343ecbea19ccac0e4b8fd828fe9f1e51d397381d882fcca3e7033198dcd025ed77b8d60a669661bbf89dc83cf954695bac8365ca3e SHA512 76e0a7f3e9402a9cf2434e13d6a75e932ca9ee84b16fc84878aad5af54d3fd469f692d93d0b97e8bd37a723fababb5e3e2eaddd8374267eb10f93357393d0fce
+EBUILD opam-installer-2.2.1.ebuild 1075 BLAKE2B 1272d7c56291d275e633e37685dd4ca531c11a85550364dba087f9cc8b45ea084bb68a7ba6345733f96ae0930bd7df2f3692ff73b4c874abb420e395d95ba040 SHA512 0812bbd8a101a92d1cc7905a1765fb502a476139071f4cccd36424d682324913d3ced26d67ecf443001785d2dc04355b301bc80677966a135c6c91d4116ee0ea
MISC metadata.xml 308 BLAKE2B 8063e47b40e4366ef330084a189eafbb580be1231caf276960a3c3a67a34f4cb60be369e2ae75b91b379feda07fc8d7b6d9ccc5fa14c296c9dc2e8bb92d10157 SHA512 0b05ce3d4265c65f2ba372a24a59bbb46b8daa80883501a61da35aa0a8a487cd5fe0cf24cd6c089139893eb1fa970c33ef207e51772583bb137ebd38ec58eca5
diff --git a/dev-ml/opam-installer/opam-installer-2.2.1.ebuild b/dev-ml/opam-installer/opam-installer-2.2.1.ebuild
new file mode 100644
index 000000000000..f9d4c4943e8b
--- /dev/null
+++ b/dev-ml/opam-installer/opam-installer-2.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Core installer for opam packages"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/releases/download/${PV}/opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test" # sandbox not working
+
+RDEPEND="
+ dev-ml/cmdliner:=[ocamlopt?]
+ dev-ml/jsonm:=[ocamlopt?]
+ dev-ml/ocamlgraph:=[ocamlopt?]
+ dev-ml/ocaml-sha:=[ocamlopt?]
+ ~dev-ml/opam-common-${PV}:=[ocamlopt?]
+ dev-ml/opam-file-format:=[ocamlopt?]
+ dev-ml/re:=[ocamlopt?]
+ dev-ml/swhid_core:=[ocamlopt?]
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/uchar:=[ocamlopt?]
+ dev-ml/uutf:=[ocamlopt?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-ml/findlib"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune-compile ${PN}
+}
+
+src_install() {
+ dune-install ${PN}
+ mv "${ED}"/usr/share/doc/${PF}/${PN}/* \
+ "${ED}"/usr/share/doc/${PF} || die
+}