summaryrefslogtreecommitdiff
path: root/dev-ml/opam/opam-1.3.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /dev-ml/opam/opam-1.3.1-r2.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'dev-ml/opam/opam-1.3.1-r2.ebuild')
-rw-r--r--dev-ml/opam/opam-1.3.1-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/opam/opam-1.3.1-r2.ebuild b/dev-ml/opam/opam-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..17c5bc14ce18
--- /dev/null
+++ b/dev-ml/opam/opam-1.3.1-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+RDEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-5:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ test? ( dev-vcs/git )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/stublibs.patch"
+}
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}