summaryrefslogtreecommitdiff
path: root/dev-ml/ordering/ordering-3.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-23 01:07:24 +0000
commit57c2e006d0af9ab77ced676461d7100cade4a716 (patch)
treefedd61a96505af97dea0e78425b1b7a70b813a46 /dev-ml/ordering/ordering-3.2.0.ebuild
parent664924d8659185e3b43f99ee8a0b88177efb93dc (diff)
gentoo auto-resync : 23:11:2022 - 01:07:24
Diffstat (limited to 'dev-ml/ordering/ordering-3.2.0.ebuild')
-rw-r--r--dev-ml/ordering/ordering-3.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ordering/ordering-3.2.0.ebuild b/dev-ml/ordering/ordering-3.2.0.ebuild
new file mode 100644
index 000000000000..f0f530285fd0
--- /dev/null
+++ b/dev-ml/ordering/ordering-3.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune multiprocessing
+
+DESCRIPTION="Element ordering"
+HOMEPAGE="https://github.com/ocaml/dune"
+SRC_URI="https://github.com/ocaml/dune/archive/${PV}.tar.gz
+ -> dune-${PV}.tar.gz"
+S="${WORKDIR}/dune-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+BDEPEND=">=dev-ml/dune-3"
+DEPEND=">=dev-lang/ocaml-4.08"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ dune build -p "${PN}" @install -j $(makeopts_jobs) --profile release || die
+}