summaryrefslogtreecommitdiff
path: root/dev-ml/parmap/parmap-1.2.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-ml/parmap/parmap-1.2.4-r1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-ml/parmap/parmap-1.2.4-r1.ebuild')
-rw-r--r--dev-ml/parmap/parmap-1.2.4-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/parmap/parmap-1.2.4-r1.ebuild b/dev-ml/parmap/parmap-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..2cab0f41c790
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.2.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
+HOMEPAGE="https://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator:="
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"