summaryrefslogtreecommitdiff
path: root/dev-ml/pcre-ocaml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /dev-ml/pcre-ocaml
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/Manifest2
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/Manifest b/dev-ml/pcre-ocaml/Manifest
index 1dc760a1630c..66c929f4888b 100644
--- a/dev-ml/pcre-ocaml/Manifest
+++ b/dev-ml/pcre-ocaml/Manifest
@@ -1,3 +1,5 @@
DIST pcre-ocaml-7.4.6.tbz 41027 BLAKE2B 1faecd96cb6f7af248e8ace7409a49131f5c654320f8ac432fd4aff602d0c4187733419e9cc73ca52cf0a3e5b725afa9357fe9ec191bf1ca42d4dc47a36e45b7 SHA512 a356c78dc19d3b3741d1fa0277c4fb0cb545f12499165526fae80a0ff8a7b1f1e6e5e916b16f8336bcec3661de811686b814fe4afc677965fec7a63d4fc53b1f
+DIST pcre-ocaml-7.5.0.tbz 41158 BLAKE2B 6bd16345bd915c236d727daeb5862c2aff677c394f10b4d040ce46003255f3fd5589801979cdd77c20d8ba4fceb443467cf8f38a379a86fc59ca513e69aa1b79 SHA512 be60f13ddb6bbfe20e30ca5d92434d85e1d1371479e1e2c725588af83fcc9366ed0435021b6a800c20336ac521f2134c767420136438684656a44ac1f9924be4
EBUILD pcre-ocaml-7.4.6-r2.ebuild 724 BLAKE2B d699ebf384cd2b3a0a8f3373b09f6c273cf8b4e9f56ec885560c5cd13ecfff80aa0755aa0ad9b514ef3488bb129dd7d426c8f0d2352666b8b760590bbbf79958 SHA512 d45352e53ac327f3a5cd8dce199f8671c315b0d5ad6e087a1490577170937d534c6a15f23e96b5f176873a16c79f104454c024088cfdac6e311ab8ff4f2c7e28
+EBUILD pcre-ocaml-7.5.0.ebuild 749 BLAKE2B 268a9a0ef646e6a9227c32f95ea34a31de05448cd691ddf87a6458dbcdeafa1fadcae3aab2cc97e40f3e0e50a74e63023ac1e8bc34efa8f4b7337fc503bf3ca1 SHA512 03d7437a5c996649337807e874a7b2d9eb90c5adccdbd24a3847a39c27afede0d441c4e8152a076f3bce845b4b9f8f8d20d3f34ce8bab956a77250af016f0054
MISC metadata.xml 387 BLAKE2B 3cc3f72757575c7ef774afb844b7ade41a0fc8e5679e0679143f8a0e36c55b26c056962075acccd91bdf77b16a2068601d48ee21573ed9e6e9e162a1fd46cdbb SHA512 f3c7c2cbaf4fab907509c97d3638718604905da35896ffbd14772e03ffdd45b08faacb0a0efe93cef4b27875fa0c27712a6f3c1e0d75cf6cc6416d9378573c50
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
new file mode 100644
index 000000000000..8351c029f26d
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+S="${WORKDIR}/pcre-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples +ocamlopt"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-libs/libpcre-4.5
+ dev-ml/stdio:=
+ >=dev-lang/ocaml-4.12"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune_src_install pcre
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+}