summaryrefslogtreecommitdiff
path: root/dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild
new file mode 100644
index 000000000000..0a85bb949138
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-4.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit opam
+
+MY_P="postgresql-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/${PV}/${MY_P}.tbz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE=""
+
+RDEPEND="
+ dev-db/postgresql:=[server]
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ jbuilder build @install || die
+}
+
+src_install() {
+ opam_src_install "postgresql"
+}