summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 02:49:59 +0000
commite53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (patch)
treedd095d36490410a724fd271fcdf08c31a5336edd /dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
parentc5ee568457ac776b65b71fa444e0dd47535bc44a (diff)
gentoo auto-resync : 28:01:2023 - 02:49:59
Diffstat (limited to 'dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild')
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
new file mode 100644
index 000000000000..d8677fbe1e82
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.7.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="JSON codec generator for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving_yojson/"
+SRC_URI="https://github.com/ocaml-ppx/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ppxlib-0.26.0:=
+ dev-ml/ppx_deriving:=
+ dev-ml/result:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ounit2 )"