summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_globalize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 19:43:35 +0100
commitb7efdd771aad99c9a6509a5f85a80a1f7cfd55f3 (patch)
tree02f9d01894c5e75c1d01e1c85038384cb6d1da64 /dev-ml/ppx_globalize
parente2e7cc7d880b593b2bc94bf648dff853c97225f2 (diff)
gentoo auto-resync : 30:06:2023 - 19:43:35
Diffstat (limited to 'dev-ml/ppx_globalize')
-rw-r--r--dev-ml/ppx_globalize/Manifest3
-rw-r--r--dev-ml/ppx_globalize/metadata.xml15
-rw-r--r--dev-ml/ppx_globalize/ppx_globalize-0.16.0.ebuild23
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ppx_globalize/Manifest b/dev-ml/ppx_globalize/Manifest
new file mode 100644
index 000000000000..d06b5ab41ede
--- /dev/null
+++ b/dev-ml/ppx_globalize/Manifest
@@ -0,0 +1,3 @@
+DIST ppx_globalize-0.16.0.tar.gz 8328 BLAKE2B e8ba1a500fc244d53d07dbe90df6b18f3088c9496d309002a177725e1990b8108c6972dd2b45caeecdbad62c466e73ee3ae944701dec489c2613a8b71ea88787 SHA512 76618dc1cc436c437e7911a2b793233f9bdd559dc37419df6f94143548bcfe09a0f29eafc3a36e97a5f8fb886aa94ca641f10f56078a8558f642a2cf564e4c75
+EBUILD ppx_globalize-0.16.0.ebuild 557 BLAKE2B dfc61daad8b1125ff44f1e8a0020817eb465cd8de3748ddbfb812ca2158a50971fcb5a459fc6e7f95bd4840bb464dcfe9480f83abc8bc1e924342861f43ce027 SHA512 68f8f9c76addad33159197a84f0b573c11b17a653326a22c9febe44e7c52b5db648ecdf16981842d9264549d9d112c2b2cd8d17f344d1a80cc5a8a544f21a3c2
+MISC metadata.xml 427 BLAKE2B 4ad3e7d0bac6d96c8a550fb65f291d2283e2cfb65e8715852cb4f706e0cdaa983613073535a2e2c3d7820e0dde8a918f9255b70c3fe9cc918ca45b12970dba31 SHA512 a93d451215c39b24a252e0a653398b00203b1f0471a0459b5a40c5844416dc46ba73413f949c351a8629e4f6b2309139b28d39f84c4c96f238d1daf01057a938
diff --git a/dev-ml/ppx_globalize/metadata.xml b/dev-ml/ppx_globalize/metadata.xml
new file mode 100644
index 000000000000..f90eb7fdcdae
--- /dev/null
+++ b/dev-ml/ppx_globalize/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/ppx_globalize</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ppx_globalize/ppx_globalize-0.16.0.ebuild b/dev-ml/ppx_globalize/ppx_globalize-0.16.0.ebuild
new file mode 100644
index 000000000000..c4d019a043e9
--- /dev/null
+++ b/dev-ml/ppx_globalize/ppx_globalize-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Generates functions to copy local values to the global heap"
+HOMEPAGE="https://github.com/janestreet/ppx_globalize"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ >=dev-ml/ppxlib-0.28:=
+"
+RDEPEND="${DEPEND}"