summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild')
-rw-r--r--dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
new file mode 100644
index 000000000000..d01ce62cd244
--- /dev/null
+++ b/dev-ml/ppx_optcomp/ppx_optcomp-0.14.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Optional compilation for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_optcomp"
+SRC_URI="https://github.com/janestreet/ppx_optcomp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+"
+RDEPEND="${DEPEND}"