summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-30 01:36:49 +0000
commit65e0298c5630af19b2b181c2dd143bb47aa54231 (patch)
tree4dfaf06d77acbaff8f85b3d5f9848b01ab7fe236 /dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild
parentd5f4fe0e51ffa8d74055615bc4f0e2e950b5dadb (diff)
gentoo auto-resync : 30:12:2023 - 01:36:49
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild
new file mode 100644
index 000000000000..3db1a61dc337
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ =dev-ml/base-0.14*:=[ocamlopt?]
+ dev-ml/findlib:=[ocamlopt?]
+ >=dev-ml/ppxlib-0.22.0:=[ocamlopt?]
+ <dev-ml/ppxlib-0.26.0:=[ocamlopt?]
+ dev-ml/ocaml-compiler-libs:=[ocamlopt?]
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=[ocamlopt?]
+ dev-ml/cinaps:=[ocamlopt?]
+ dev-ml/sexplib0:=[ocamlopt?]
+"
+RDEPEND="${DEPEND}"