summaryrefslogtreecommitdiff
path: root/dev-ml/ppx_tools/ppx_tools-6.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-ml/ppx_tools/ppx_tools-6.5.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-ml/ppx_tools/ppx_tools-6.5.ebuild')
-rw-r--r--dev-ml/ppx_tools/ppx_tools-6.5.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/ppx_tools/ppx_tools-6.5.ebuild b/dev-ml/ppx_tools/ppx_tools-6.5.ebuild
new file mode 100644
index 000000000000..374fa202c924
--- /dev/null
+++ b/dev-ml/ppx_tools/ppx_tools-6.5.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV=$(ver_rs 2 '+')
+DESCRIPTION="Tools for authors of ppx rewriters"
+HOMEPAGE="https://github.com/alainfrisch/ppx_tools"
+SRC_URI="https://github.com/alainfrisch/ppx_tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-$(ver_rs 2 '-')"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/cppo
+"