summaryrefslogtreecommitdiff
path: root/dev-ml/ptmap/ptmap-2.0.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-27 03:56:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-27 03:56:50 +0100
commit6e8f2ebdce568f2c6c7870edbb9db5324a0e300f (patch)
tree92c92750f9317885d396064e90145eb463b3b8eb /dev-ml/ptmap/ptmap-2.0.5-r2.ebuild
parent97e5ac8a082d0d11fc18e8b8994a78e8d155899e (diff)
gentoo auto-resync : 27:10:2022 - 03:56:50
Diffstat (limited to 'dev-ml/ptmap/ptmap-2.0.5-r2.ebuild')
-rw-r--r--dev-ml/ptmap/ptmap-2.0.5-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/ptmap/ptmap-2.0.5-r2.ebuild b/dev-ml/ptmap/ptmap-2.0.5-r2.ebuild
new file mode 100644
index 000000000000..2213fb278c04
--- /dev/null
+++ b/dev-ml/ptmap/ptmap-2.0.5-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Maps of integers implemented as Patricia trees"
+HOMEPAGE="https://github.com/backtracking/ptmap/"
+SRC_URI="https://github.com/backtracking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.07:=[ocamlopt?]
+ dev-ml/stdlib-shims:=
+"
+DEPEND="${RDEPEND}"