summaryrefslogtreecommitdiff
path: root/dev-ml/reason/reason-3.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-ml/reason/reason-3.7.0-r2.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-ml/reason/reason-3.7.0-r2.ebuild')
-rw-r--r--dev-ml/reason/reason-3.7.0-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/reason/reason-3.7.0-r2.ebuild b/dev-ml/reason/reason-3.7.0-r2.ebuild
new file mode 100644
index 000000000000..4836114dfded
--- /dev/null
+++ b/dev-ml/reason/reason-3.7.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io"
+SRC_URI="https://registry.npmjs.org/@esy-ocaml/${PN}/-/${P}.tgz"
+S="${WORKDIR}/package"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ <dev-lang/ocaml-4.13.0:=[ocamlopt?]
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CODE_OF_CONDUCT.md HISTORY.md ORIGINS.md PLAN README.md
+ docs/GETTING_STARTED_CONTRIBUTING.md
+ docs/TYPE_PARAMETERS_PARSING.md
+ docs/USING_PARSER_PROGRAMMATICALLY.md
+)
+
+src_install() {
+ dune-install reason rtop
+ einstalldocs
+}