summaryrefslogtreecommitdiff
path: root/dev-ml/reason/reason-3.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-16 01:51:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-16 01:51:50 +0100
commit6144cd2e90f8e3623912112050c8d2025de44f0a (patch)
treebf6abe7c75cda0f602c2d522c905278a620a5cbf /dev-ml/reason/reason-3.8.2.ebuild
parentca144cbf71b2faf598564847378fa40a0090d67c (diff)
gentoo auto-resync : 16:10:2022 - 01:51:50
Diffstat (limited to 'dev-ml/reason/reason-3.8.2.ebuild')
-rw-r--r--dev-ml/reason/reason-3.8.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/reason/reason-3.8.2.ebuild b/dev-ml/reason/reason-3.8.2.ebuild
new file mode 100644
index 000000000000..29a823b9621d
--- /dev/null
+++ b/dev-ml/reason/reason-3.8.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io"
+SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CODE_OF_CONDUCT.md HISTORY.md ORIGINS.md PLAN README.md
+ docs/GETTING_STARTED_CONTRIBUTING.md
+ docs/TYPE_PARAMETERS_PARSING.md
+ docs/USING_PARSER_PROGRAMMATICALLY.md
+)
+
+src_install() {
+ dune-install reason rtop
+ einstalldocs
+}