summaryrefslogtreecommitdiff
path: root/dev-ml/spawn/spawn-0.15.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-23 05:29:14 +0100
commit7f740fcb9a0165d81bfecf7fb5da647763d76a1b (patch)
tree45dab58d8bd40ef97234398e9e1850495ea60273 /dev-ml/spawn/spawn-0.15.1.ebuild
parent0bf5c5a0b1ff93d1f4aaa8cdea6acda5e42c2068 (diff)
gentoo auto-resync : 23:09:2022 - 05:29:13
Diffstat (limited to 'dev-ml/spawn/spawn-0.15.1.ebuild')
-rw-r--r--dev-ml/spawn/spawn-0.15.1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-ml/spawn/spawn-0.15.1.ebuild b/dev-ml/spawn/spawn-0.15.1.ebuild
new file mode 100644
index 000000000000..3d2f2b12da2e
--- /dev/null
+++ b/dev-ml/spawn/spawn-0.15.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Spawning sub-processes"
+HOMEPAGE="https://github.com/janestreet/spawn"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-ml/ppx_expect )"