summaryrefslogtreecommitdiff
path: root/dev-ml/zarith
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-22 17:17:39 +0100
commitf66a06e8f9736ea679bc3e95d8c8e90ff7c3f466 (patch)
tree6e12e70b54f33f9219df2139130612649af4161d /dev-ml/zarith
parent92a9a3adda432ad2b7af58e08f5493ed6dc81196 (diff)
gentoo auto-resync : 22:09:2023 - 17:17:39
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/Manifest2
-rw-r--r--dev-ml/zarith/zarith-1.13.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/zarith/Manifest b/dev-ml/zarith/Manifest
index 12d972459321..9db5d7585ea7 100644
--- a/dev-ml/zarith/Manifest
+++ b/dev-ml/zarith/Manifest
@@ -1,4 +1,6 @@
AUX zarith-1.12-shuffle.patch 308 BLAKE2B 7c725c7ef19483a153f7404c3c91f268faf24b949042f05a7f79640d4fabd7d47722df3453b4bf705e3c1fea08784bd13b082cdea69d4932283b302dbf49db85 SHA512 851dac84670cdf2f58f59b9decf28f0a40368098422c3f90da04580f4a64e2c3527beb318ff68bcfa94a60ac99a26c2b54f3e33b4bd82c7d3cb9f23072b32614
DIST zarith-1.12.tar.gz 93695 BLAKE2B b9622e2f397887d08fb8a8520419cf459e99906c05a897af91258b17d92d3fbbd2314a0a4be8a56a07074dcb0a0d04c896b3b5e69526a6c81a8a07b657d1bfec SHA512 8075573ae65579a2606b37dd1b213032a07d220d28c733f9288ae80d36f8a2cc4d91632806df2503c130ea9658dc207ee3a64347c21aa53969050a208f5b2bb4
+DIST zarith-1.13.tar.gz 85994 BLAKE2B a5860319e17f4e660f248f3e724076b578d27dc3a06e8b54d68bcd6ed021a0354ad714dfcb06329bb9c4a3eadc3d08fd84fd76ef5d1a8902a06a7506d77addde SHA512 a562fa8bf4f5ef44f2af6b9a8f028182fd184c89f8c41455acdc02851cc0fc3124d3776c0de930e8d09cd5d6d88cc689f80f4b597068a0611131f45d057b101f
EBUILD zarith-1.12.ebuild 1429 BLAKE2B 015c4587939d5d7511d1b3e0437377b712da40c677db7069fde9f9f563475f3fc0deb16b1e3e4c4fbe74c97c1e9dc21b21de58a190be03c851d3cb55db97b43a SHA512 b3f000982657bab9e22e86b922e1ac2ac63281efa01f94ad46fdb6d68cede9c6d6ee7c51e0f2d09ddee834c776f5a01ba6a15a80ba3c97b53a0fc7b3fe179e4a
+EBUILD zarith-1.13.ebuild 1386 BLAKE2B fc4c34b5412bfa0e2d159408e662b92794474608bf3d136752ceeabaabe18ecb002f7e8f26d4deecfa2f4aea5d257cbaebe8a2d564657aef96458a61fb918267 SHA512 2c7d5a08fa4ecd84e337983bd616b817076cdd97b2319c7db50ccdf9b04bd564b4fef6fa52441ef8882541a7ca29dde6deaa96f332745f2fdd065a050284dafe
MISC metadata.xml 385 BLAKE2B b88400ffa45f84bd5bcfab6a7299ae7f961453f12a55f14dd329831a2273ded4ef2b21dcb25b2611d8590dac2850f84a0221a561d40fa65ce9d62a6ef9a75e57 SHA512 cab52bdbd8b49498a14001cef333073aab9e9496c4caef217cc37738e607a35b23d8e25c41394e976be98f822aca806a8da30773f142a70c69d2de7c8d87531c
diff --git a/dev-ml/zarith/zarith-1.13.ebuild b/dev-ml/zarith/zarith-1.13.ebuild
new file mode 100644
index 000000000000..0ecf19d7d607
--- /dev/null
+++ b/dev-ml/zarith/zarith-1.13.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib toolchain-funcs
+
+DESCRIPTION="Arithmetic and logic operations over arbitrary-precision integers"
+HOMEPAGE="https://github.com/ocaml/Zarith"
+SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="doc mpir +ocamlopt"
+RESTRICT="!ocamlopt? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.05:=[ocamlopt=]
+ !mpir? ( dev-libs/gmp:0= )
+ mpir? ( sci-libs/mpir:= )
+"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+DOCS=( README.md Changes )
+
+S="${WORKDIR}/Zarith-release-${PV}"
+
+src_configure() {
+ tc-export CC AR
+ ./configure \
+ -ocamllibdir /usr/$(get_libdir)/ocaml \
+ $(usex mpir "-mpir" "-gmp") || die
+ sed -i \
+ -e 's|$(INSTALLDIR)|$(DESTDIR)$(INSTALLDIR)|g' \
+ project.mak || die
+}
+
+src_compile() {
+ emake -j 1 HASOCAMLOPT=$(usex ocamlopt yes no) HASDYNLINK=$(usex ocamlopt yes no) all
+ use doc && emake doc
+}
+
+src_test() {
+ emake HASOCAMLOPT=yes HASDYNLINK=yes tests
+}
+
+src_install() {
+ findlib_src_preinst
+
+ emake \
+ HASOCAMLOPT=$(usex ocamlopt yes no) \
+ HASDYNLINK=$(usex ocamlopt yes no) \
+ DESTDIR="${ED}" \
+ install
+
+ dosym zarith/libzarith.a /usr/$(get_libdir)/ocaml/libzarith.a
+
+ use doc && HTML_DOCS=( html/* )
+ einstalldocs
+}