summaryrefslogtreecommitdiff
path: root/dev-ml/zed/zed-3.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-20 15:41:38 +0100
commita597364520b9291d0b2a23bb007ced022e821d95 (patch)
treefbdb29d309a73a184394006e206a8d4362ccdad8 /dev-ml/zed/zed-3.2.3.ebuild
parent1def2e3dbbf3c86abad238d1118502cfe7f61f08 (diff)
gentoo auto-resync : 20:08:2023 - 15:41:38
Diffstat (limited to 'dev-ml/zed/zed-3.2.3.ebuild')
-rw-r--r--dev-ml/zed/zed-3.2.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/zed/zed-3.2.3.ebuild b/dev-ml/zed/zed-3.2.3.ebuild
new file mode 100644
index 000000000000..8e32cbb4d079
--- /dev/null
+++ b/dev-ml/zed/zed-3.2.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Abstract engine for text edition in OCaml"
+HOMEPAGE="https://github.com/ocaml-community/zed"
+SRC_URI="https://github.com/ocaml-community/zed/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/dune-3
+ dev-ml/react:=
+ dev-ml/result:=
+ dev-ml/uchar:=
+ dev-ml/uucp:=
+ dev-ml/uuseg:=
+ dev-ml/uutf:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/alcotest
+)"