summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-22 07:21:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-22 07:21:18 +0100
commitf3fb638f09f376ec32bff303d5785b875a1c641f (patch)
treeb87371fb14d6b566de18a4dc1202f46e7061b57b /dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild
parentcb6b2150348c9dc57c68bcba47bcdb6f20e8e508 (diff)
gentoo auto-resync : 22:06:2023 - 07:21:18
Diffstat (limited to 'dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild')
-rw-r--r--dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild b/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild
new file mode 100644
index 000000000000..75e3eb18abd3
--- /dev/null
+++ b/dev-perl/Apache-AuthCookie/Apache-AuthCookie-3.310.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MSCHOUT
+DIST_VERSION=3.31
+inherit perl-module
+
+DESCRIPTION="Perl Authentication and Authorization via cookies"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=www-apache/mod_perl-2
+ virtual/perl-Carp
+ >=dev-perl/Class-Load-0.30.0
+ virtual/perl-Encode
+ dev-perl/HTTP-Body
+ dev-perl/Hash-MultiValue
+ dev-perl/WWW-Form-UrlEncoded
+ >=dev-perl/URI-1.360.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Apache-Test-1.390.0
+ >=virtual/perl-Test-Simple-0.940.0
+ !www-apache/mpm_itk
+ )
+"
+
+src_test() {
+ perl_rm_files t/author-* t/signature.t
+ perl-module_src_test
+}