summaryrefslogtreecommitdiff
path: root/dev-perl/Apache-Test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-perl/Apache-Test
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-perl/Apache-Test')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild34
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild36
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.400.0-r1.ebuild36
-rw-r--r--dev-perl/Apache-Test/Manifest9
-rw-r--r--dev-perl/Apache-Test/metadata.xml50
5 files changed, 165 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild b/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild
new file mode 100644
index 000000000000..af221909bc99
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.380.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.38
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild
new file mode 100644
index 000000000000..98df7dcdf72c
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.390.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.39
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/Apache-Test-1.400.0-r1.ebuild b/dev-perl/Apache-Test/Apache-Test-1.400.0-r1.ebuild
new file mode 100644
index 000000000000..ce1c41929cec
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.400.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_AUTHOR=SHAY
+MODULE_VERSION=1.40
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND="virtual/perl-ExtUtils-MakeMaker"
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl_set_version
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}
diff --git a/dev-perl/Apache-Test/Manifest b/dev-perl/Apache-Test/Manifest
new file mode 100644
index 000000000000..33370b4242ae
--- /dev/null
+++ b/dev-perl/Apache-Test/Manifest
@@ -0,0 +1,9 @@
+DIST Apache-Test-1.38.tar.gz 150863 SHA256 321717f58636ed0aa85cba6d69fc01e2ccbc90ba71ec2dcc2134d8401af65145 SHA512 416a89990e1947dfd970b806a28b52197165bbe1a482402aa5649f6e2692866a54cc8a4a7adcce83350e2f16aada409fd6c506c0d139b624319c5ebaa58604cc WHIRLPOOL 6f5724b9e56dcd268c8dfa3469b85e6f3f9ef02e9e524386d0af12377d9e560831155913392f04ef9e7b130b0b495e1e5e013a52cd0f4c747507f8f845665e6c
+DIST Apache-Test-1.39.tar.gz 151240 SHA256 d8543864ff29e8ac3d4004c5c7014b1fe490b2024104ac4c24683a74bba62089 SHA512 4f10b0ed856d03aff27aa80d9788f0a2f50eac3523cc7ecf74fec2cda4c881fda2ec096ca238539eb8c4aa2caa4daaa192456f34d00ad8012276c1d87fcc3533 WHIRLPOOL 01a77e14a1464a0caa8154dd4ff68b6b6dc5e7220ae1d4efe63e2a9eb2134ec94d0d5b73c6701de21c0a7d620d1e4bfe2db768c2cd08d9a984609bb7186beaea
+DIST Apache-Test-1.40.tar.gz 151801 SHA256 3cf537f1c81deb549d62be7fd5ee1af439283a9e93f3d13465d01a1d41d4ae40 SHA512 f48a1b93c4d61181670ec59bb8bb2231122b22ec9725d8899a3b2f82d2918fdc48a09494c2f45b0e6a603546481892a948eac3494e06c8eb219a9213e1faadb8 WHIRLPOOL 9456d81354cf4fc22fb67d35053daba43fb0fcdcc6c3ef2c537a6996268371db988bbc335635e3557104430c35ddefbb6a455a8da83eb00fba648fb7cfb17656
+EBUILD Apache-Test-1.380.0-r1.ebuild 702 SHA256 2e6c510e19a290d48b4641b53b8f4e8c5d1dc344a9317442c6b0012807f2df92 SHA512 7ea1d14c691f16ae5797d0d553bddd5c45b24b74e5bd13f98f126c4cce2654989a039b3dcac18153cc68d33e44bb5a1948b38253a20b991b6ac661e70a659a37 WHIRLPOOL d20402a42075f9cb9352251aedae5c4347593cfff8a12af34d27295836fbd3674a90a7ba2ad6057406ea37e7e3140f934fa98c658dec9e75937f64374e5049e5
+EBUILD Apache-Test-1.390.0.ebuild 754 SHA256 ba6dc1311776e0361e76ef26dc6f44efc3c570a2c49e7373a50948424cbbebb5 SHA512 4d4642738553febf2b2f70f2f3d73ddd86bef2c4d3be15b919d8d84bad1d78d74f68b057ccbd51950445172808a6df015088a4563c91659a3f5a5a11f2411e45 WHIRLPOOL a0e791a1a2616daaf23d0c23b89be22d64037a69cee0696ae3cb05ddc669ef7be26d7a109e172fb6b1519d7bf3145407ae7110b64034ff2cfe61a26876029567
+EBUILD Apache-Test-1.400.0-r1.ebuild 751 SHA256 81c71a1bdc1443a3959f0919ace59246859d2d8c0f1ce97300ea535de87b58ea SHA512 98c6815e5ece4196621fcb12e4695f861c84e66adeb7860ad33b46e8653b266e96336628c0d7374d61f5b25e65d37c76073efc39d9ed9ad879f7a2bcf5db9b97 WHIRLPOOL 5794762a92d1b90b030778d360cb4b58bc50b9d112f8ff46c618342d239cde97499398745d1d54f0f23fd3b6e6b47b3e37273f0810524ca6c1127f66c66e9110
+MISC ChangeLog 3724 SHA256 93681aecac27872037067fa6e89e3d3079d5c69e6a86a80a6cbbadb3e316edb8 SHA512 ef5dec103c105545f3dd267b2ed3799bf4ca8dd9c0528240271a6c466528f5c2b912ee854397344ad78087299ebed36dd444449725f9268df92fa82609e11171 WHIRLPOOL 580471a29ee6256cca56fa7ef8de3bff07a1401df36d8e3c46cd047d06fadfd52fdb3b2a018eb1d1145170132b5728a219ca5e67d88201e18ef2d00a5613ea55
+MISC ChangeLog-2015 13033 SHA256 9e29143ecc9a3c382de7e7c14ccab43daa69d5c25f331f01daad9dbe0b076048 SHA512 96f87bd59376d6a9eb3ff965380022f42b37f7b3fbc0b74769a9009eede209474bff0626435dbe4bf571ec188443c804097db6208a42c88f7c6a0b9f40f75037 WHIRLPOOL c6d9ef3eba8f6740441086cba198343af270a5a6cb3599c3571010a02e315dbbff69c41edc0920954d82660b19c937c371ee98bb136053cae803c2cac2872b7e
+MISC metadata.xml 2858 SHA256 87acbbe6a536ae097daa2bacd25a492762329e5fd445fb4fa348ee9b9828df58 SHA512 1db84f146dd887e3719328aba99809ac3ba8462226b9109310675b1722b2874cddd54b82900852082160bd47bf157611ba9f324d1f2964ee6912d4bff3690517 WHIRLPOOL e7872451d1ad490a62c71a4cfcc1be445f36d27cf257ba702717d54900e6289676b00fc9aa75d36bf2d96602016b2c0c269bf5b818cf4bb75a2b96feb1394d70
diff --git a/dev-perl/Apache-Test/metadata.xml b/dev-perl/Apache-Test/metadata.xml
new file mode 100644
index 000000000000..9a11d8f604ef
--- /dev/null
+++ b/dev-perl/Apache-Test/metadata.xml
@@ -0,0 +1,50 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription>The Apache::Test framework was designed for creating test
+ suites for products running on the Apache httpd webserver (not
+ necessarily mod_perl). Originally designed for the mod_perl Apache
+ module, it was extended to be used for any Apache
+ module.</longdescription>
+ <upstream>
+ <remote-id type="cpan">Apache-Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test</remote-id>
+ <remote-id type="cpan-module">Apache::Test5005compat</remote-id>
+ <remote-id type="cpan-module">Apache::TestBuild</remote-id>
+ <remote-id type="cpan-module">Apache::TestClient</remote-id>
+ <remote-id type="cpan-module">Apache::TestClientResponse</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommon</remote-id>
+ <remote-id type="cpan-module">Apache::TestCommonPost</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfig</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigC</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestConfigParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestHandler</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarness</remote-id>
+ <remote-id type="cpan-module">Apache::TestHarnessPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestMB</remote-id>
+ <remote-id type="cpan-module">Apache::TestMM</remote-id>
+ <remote-id type="cpan-module">Apache::TestReport</remote-id>
+ <remote-id type="cpan-module">Apache::TestReportPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestRequest</remote-id>
+ <remote-id type="cpan-module">Apache::TestRun</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPHP</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunParrot</remote-id>
+ <remote-id type="cpan-module">Apache::TestRunPerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSSLCA</remote-id>
+ <remote-id type="cpan-module">Apache::TestServer</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmoke</remote-id>
+ <remote-id type="cpan-module">Apache::TestSmokePerl</remote-id>
+ <remote-id type="cpan-module">Apache::TestSort</remote-id>
+ <remote-id type="cpan-module">Apache::TestToString</remote-id>
+ <remote-id type="cpan-module">Apache::TestTrace</remote-id>
+ <remote-id type="cpan-module">Apache::TestUtil</remote-id>
+ <remote-id type="cpan-module">Bundle::ApacheTest</remote-id>
+ <remote-id type="cpan-module">HTTP::Request::Common</remote-id>
+ <remote-id type="cpan-module">warnings</remote-id>
+ </upstream>
+</pkgmetadata>