summaryrefslogtreecommitdiff
path: root/dev-perl/Apache2-AuthenNTLM
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Apache2-AuthenNTLM
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Apache2-AuthenNTLM')
-rw-r--r--dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild40
-rw-r--r--dev-perl/Apache2-AuthenNTLM/Manifest3
-rw-r--r--dev-perl/Apache2-AuthenNTLM/metadata.xml21
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild b/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild
new file mode 100644
index 000000000000..fe97a1931547
--- /dev/null
+++ b/dev-perl/Apache2-AuthenNTLM/Apache2-AuthenNTLM-0.20.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SPEEVES
+DIST_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Perform Microsoft NTLM and Basic User Authentication"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/perl-MIME-Base64
+ >=www-apache/mod_perl-2"
+DEPEND="${RDEPEND}"
+
+src_test() {
+ local MODULES=(
+ "Apache2::AuthenNTLM ${DIST_VERSION}"
+ "Authen::Smb 0.96"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Apache2-AuthenNTLM/Manifest b/dev-perl/Apache2-AuthenNTLM/Manifest
new file mode 100644
index 000000000000..cdef81028897
--- /dev/null
+++ b/dev-perl/Apache2-AuthenNTLM/Manifest
@@ -0,0 +1,3 @@
+DIST Apache2-AuthenNTLM-0.02.tar.gz 51597 BLAKE2B 9392d255cb5867e2c5216f85ec0f4db330e728936e78209eec5ceeebf9f9f594391e0885c3798813644bd1c5da5ea697b8db06e8b38bec7fc7bcea79d0e8858a SHA512 783ca41ee2b4c89d5d793dcbd00c2bf4d58842825e56933bdeb8b74c35f38e5a6d32c49987f938a801f9cc3555922423afb10cb182b8160de29f4a082c1b9ee3
+EBUILD Apache2-AuthenNTLM-0.20.0-r2.ebuild 840 BLAKE2B e384cb6d26ed5fe2a9b03f4f1bfe0e7b5dd708a26a59f25bf55e9e0f67a0dd0c498c5145d016063dd55631a5d8373b944353389e894096d35d4d090e2e44eb0b SHA512 b96527fd53047b77414929b479a18d96e16d5b7cda18ad9d7159f930b6ce4917e1872e08274e954fe76f548fd2bf5baa0ea99b0b9a7338d8b1c367405c273aa3
+MISC metadata.xml 930 BLAKE2B 95e6ccc573ed61c488b0ef8c181cfecf593c0f96a944a7870f57fcdd5b513a67cb4a3b9e855ba6360c5b2edce2c7683e7ab9d018f6c8689d5d0307818dd14f4e SHA512 b7805c859a2a1eb602df61e58938f82fddff98da80cbad47d87ec360a5e0ff5ac45e7aa51f00b8682c4745ae705141b9c0899cb585d6a5ea009b67e666c405ec
diff --git a/dev-perl/Apache2-AuthenNTLM/metadata.xml b/dev-perl/Apache2-AuthenNTLM/metadata.xml
new file mode 100644
index 000000000000..4e1be189080f
--- /dev/null
+++ b/dev-perl/Apache2-AuthenNTLM/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <longdescription lang="en">
+The purpose of this module is to perform a user authentication via Microsoft's
+NTLM protocol. This protocol is supported by all versions of the Internet
+Explorer and is mainly useful for intranets. Depending on your preferences
+setting IE will supply your windows logon credentials to the web server when the
+server asks for NTLM authentication. This saves the user to type in his/her
+password again.
+</longdescription>
+ <upstream>
+ <remote-id type="cpan">Apache2-AuthenNTLM</remote-id>
+ <remote-id type="cpan-module">Apache2::AuthenNTLM</remote-id>
+ <remote-id type="cpan-module">Apache2::AuthenNTLM::Lock</remote-id>
+ </upstream>
+</pkgmetadata>