summaryrefslogtreecommitdiff
path: root/dev-perl/Audio-CD-disc-cover
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-23 00:06:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-23 00:06:40 +0100
commitb3b92de25c3fc5f6bddc5e513027140591a0b2a5 (patch)
treef2ce6d7e747abea3e8fa7d99e32ad5d98cf33988 /dev-perl/Audio-CD-disc-cover
parent236e75597883501f8700d9ba1a5c8276f578a17f (diff)
gentoo auto-resync : 23:05:2024 - 00:06:39
Diffstat (limited to 'dev-perl/Audio-CD-disc-cover')
-rw-r--r--dev-perl/Audio-CD-disc-cover/Audio-CD-disc-cover-0.05-r4.ebuild59
-rw-r--r--dev-perl/Audio-CD-disc-cover/Manifest3
-rw-r--r--dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99-2.patch11
-rw-r--r--dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99.patch23
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-perl/Audio-CD-disc-cover/Audio-CD-disc-cover-0.05-r4.ebuild b/dev-perl/Audio-CD-disc-cover/Audio-CD-disc-cover-0.05-r4.ebuild
new file mode 100644
index 000000000000..a958cf3b14d0
--- /dev/null
+++ b/dev-perl/Audio-CD-disc-cover/Audio-CD-disc-cover-0.05-r4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# This appears it should really be entitled Audio-CD
+# There are * QA Notice: errors on building however the HOMEPAGE gives no source repo in which to file
+# prob. not worth the trouble for this little script.
+
+DIST_EXAMPLES=("eg/*")
+inherit perl-module
+
+MY_P=Audio-CD-${PV}
+DESCRIPTION="Perl Module needed for app-cdr/disc-cover"
+HOMEPAGE="http://www.vanhemert.co.uk/disc-cover.html"
+SRC_URI="http://www.vanhemert.co.uk/files/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+RDEPEND=">=dev-perl/URI-1.10
+ >=dev-perl/HTML-Parser-3.15
+ >=virtual/perl-MIME-Base64-2.12
+ >=virtual/perl-Digest-MD5-2.12
+ >=virtual/perl-libnet-1.0703-r1
+ >=dev-perl/libwww-perl-5.50
+ >=media-libs/libcdaudio-0.99.6
+"
+DEPEND="
+ >=media-libs/libcdaudio-0.99.6
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/Audio-CD-disc-cover-0.05-c99.patch
+ "${FILESDIR}"/Audio-CD-disc-cover-0.05-c99-2.patch
+)
+
+src_test() {
+ local MODULES=(
+ "Audio::CD ${PV}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Audio-CD-disc-cover/Manifest b/dev-perl/Audio-CD-disc-cover/Manifest
index a239ceb9a03c..cafcfa8eddd2 100644
--- a/dev-perl/Audio-CD-disc-cover/Manifest
+++ b/dev-perl/Audio-CD-disc-cover/Manifest
@@ -1,3 +1,6 @@
+AUX Audio-CD-disc-cover-0.05-c99-2.patch 268 BLAKE2B e8bdc683334430136aeabcbf9480ed14d9959d5bb2403b3faf7b06f9aba3730e7b08364152cfaada5e00c63e02dc13264408cb47f272b044f41661bea8146bc3 SHA512 c397146563ae81bdd7c965443bae66b281a1218a8956a52a31a84a479e01e1317262a61fba8939369902693f1e10e178db27cc3bbd61d95665ed4caab6c750e5
+AUX Audio-CD-disc-cover-0.05-c99.patch 551 BLAKE2B 56d3a6b8f5ab76ecc3f395a7d01439b81d30cd588ba2137a508a63f332fae6dbca7178d9ddb9bbd77df1bf48d3686df10e07668fcf767b45da6c8df1c2ec45a8 SHA512 6c57cdfe878ca292054d7e4b16cd804f8d3b033f61e54ba211c5c93912d21a901a048a9222de496e2eebaff87b1ce4a7b7fe6ac2968d0d1552232e294de8dc26
DIST Audio-CD-0.05.tar.gz 10417 BLAKE2B d33b3286966af96df05d8e7228dc19b4752c4d2e48ba39a9b3b6594e4bfe82b0ba7b70e29bc8ebb39b9a7e7bf8000dde1abe01197600a651d5a2441c707fd161 SHA512 c4d9a6ff57119431315329a92accf9c0f6b4fd52d1fbf9d6c79743b50ac73ebddc6b541a7807344d6eefd12a7681945b4ee3885abfe32acb68b9d17d070d6d09
EBUILD Audio-CD-disc-cover-0.05-r3.ebuild 1430 BLAKE2B 038bc148ed14e435d280b0329cb2a6d7a2053ccc1b36ffad5cfd6504cdec0b1313061f5dd6f18241f96bba348cdcc761b5970b108f61a91ec78186204d2367a4 SHA512 c1d41816fe33471693daa1f320c242c05846ca2f865460f4d810dff69f532fa20962a5246e1ecaa69b4b03676eefb96b1cdb6da933a4a65ba5b519c9d8d1898f
+EBUILD Audio-CD-disc-cover-0.05-r4.ebuild 1471 BLAKE2B 68e4ccbb457e474de212e4a3f15d498f4587bea9d004184e406acb26cdefd5deb1c18c8e68b7832a9fe70259e4d52d92ed4defdc2d5e1f952bd79b1f89a286b8 SHA512 37f14759786bcdb537edf77a4316ac7aad1eaf4be9c7a639efca06556f9e9f7840a011f60cad300a4b42446e18faa6afb337585e3e4330c63170f10a1a6ade9c
MISC metadata.xml 389 BLAKE2B 2fea736d9d98f11de362d946f1add56a37432a2695fb76f1b962973469e7063ea46aa20b0af5016961fb125769632d8000ee6804d24bfb67fb316c1314bc29ba SHA512 004bb927cd81ef2201abd2b5f3e910181f38150192c59daca56849bcc9bf044c9a368b923a6a827ffbb601e3b4d5c7b8b24328cff01fc8ca3e11315b0bdfe4eb
diff --git a/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99-2.patch b/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99-2.patch
new file mode 100644
index 000000000000..4bb760467935
--- /dev/null
+++ b/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99-2.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/874972
+--- a/cddb_lookup.c
++++ b/cddb_lookup.c
+@@ -25,6 +25,7 @@ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ #include <string.h>
+ #include <sys/socket.h>
+ #include <signal.h>
++#include <unistd.h>
+
+ #define PACKAGE "Audio::CD"
+
diff --git a/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99.patch b/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99.patch
new file mode 100644
index 000000000000..289ff3663040
--- /dev/null
+++ b/dev-perl/Audio-CD-disc-cover/files/Audio-CD-disc-cover-0.05-c99.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/874972
+https://rt.cpan.org/Public/Bug/Display.html?id=152236
+
+Description: add more #includes
+ for building with -Werror=implicit-function-declaration
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/1065762
+Author: gregor herrmann <gregoa@debian.org>
+Last-Update: 2024-03-10
+
+--- a/cddb_lookup.c
++++ b/cddb_lookup.c
+@@ -21,6 +21,10 @@
+ #include "cdaudio.h"
+ #include "cddb_lookup.h"
+ #include "stdio.h"
++#include <stdlib.h>
++#include <string.h>
++#include <sys/socket.h>
++#include <signal.h>
+
+ #define PACKAGE "Audio::CD"
+